← Back to team overview

ac100 team mailing list archive

Re: [Question #247956]: Wifi doesn't work in Lubuntu 14.04


Question #247956 on AC100_enablement changed:

Description changed to:
Hello I have just installed Lubuntu 14.04 on a AC100. I cannot make wifi work in Lubuntu anyway.
I have set up dual-boot with Android and when I boot in this last one, wifi works flawlessly.
I have a feeling that there is some problems with USB power management.

The kernel doesn't load the rt2800usb module. There are some errors in dmesg of the type:
usb 1-1: device descriptor read/64, error -71
usb 1-1: device not accepting address 4, error -71

I tried to boot the kernel with the "usbcore.autosuspend=-1" and "usbcore.old-scheme-first=1" options.
I have tried to unplug everything and wait 5 minutes before rebooting.

here some useful logs:
lsmod - https://drive.google.com/file/d/0B0VJUB4eOu4LRDlEU1NGVHJNSm8/edit?usp=sharing
uname - https://drive.google.com/file/d/0B0VJUB4eOu4LRXRscU01QU5fQ28/edit?usp=sharing
dmesg - https://drive.google.com/file/d/0B0VJUB4eOu4LSDhCWUFUQTJ4TGc/edit?usp=sharing
modinfo rt2800usb - https://drive.google.com/file/d/0B0VJUB4eOu4LX2N0NkhZaUtlZ2s/edit?usp=sharing
boot.cmd - https://drive.google.com/file/d/0B0VJUB4eOu4LcHRQY1JVOVF1bTQ/edit?usp=sharing

PS I upgraded the kernel from the stock version. Since I use a usb-ethernet adapter I haven't tested wifi on the stock kernel.
To upgrade I simply used apt-get, is that wrong?

You received this question notification because you are a member of
AC100 Team, which is an answer contact for AC100_enablement.