← Back to team overview

ac100 team mailing list archive

Uboot hangs after "Starting kernel" message


Hi @ all,
I compiled a kernel for my AC100 and want to boot it via uboot. Problem: After displaying the message "Starting Kernel" nothing happens. The flag CONFIG_DEBUG_LL was set but there is still no output after this message. I use the dtb file arch/arm/boot/dtbs/tegra20-paz00.dtb from the extracted kernel archive.

I installed uboot like it is described here: https://paz00.ru/index.php?title=Uboot_installation&setlang=en After installation there is a kernel image named zImage-sos in mmcblk0p1 and a related dtb file named paz00_sos.dtb. This kernel boots fine if use the paz00_sos.dtb, but if I use the tegra20-paz00.dtb file it shows the same behavior like my self-compiled kernel (hangs after "Starting kernel" message).

So I guess my problem is related to the dtb file I use for my kernel. What could I do to get some information what the problem is?

I also tried to use the paz00_sos.dbt for my self compiled kernel, but this does not work.

Would be very happy if anyone could help :)

Regards, Felix