← Back to team overview

asus-ul30 team mailing list archive

Re: U35F-X1 flipped webcam


I had this problem on my U33JC running Arch Linux and fixed it last night after reading something on the web (can't remember where, just searched Google). I run Skype using the following script:

export LIBV4LCONTROL_FLAGS=3 && LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

I did not recompile anything. Note my path has lib32 in it; it's a 32-bit library on my 64-bit system. It's also at a different path than yours. Try adding the "export LIBV4LCONTROL_FLAGS=3 &&" portion in front of your current command and see what happens.


On 09/18/2010 01:42 PM, Albert Vilella wrote:
thanks very much for the info. I think this is the first U35F on the
list, but there might
be similar models in terms of webcam tweaks...

On Sat, Sep 18, 2010 at 8:24 PM, Marius Jigmond<mjigmond@xxxxxxxxx>  wrote:
Hi all,

Most things run fine on Ubuntu 10.10 Beta. The only problem is the
flipped webcam. libv4l0 0.8.0 from Debian didn't help. I compiled 0.8.1
and launched Skype with $LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
skype but it's still flipped. I also added my camera/laptop info to
libv4lcontrol.c, re-compiled, and still no luck.

Lines added:
        { 0x064e, 0xa136, 0, "ASUSTeK Computer Inc.        ", "U35F
lsusb: Bus 001 Device 003: ID 064e:a136 Suyin Corp.

Any ideas out there?

This message was sent from Launchpad by
Marius Jigmond (https://launchpad.net/~mjigmond)
to each member of the ASUS U/UL Series laptop team using the "Contact this
team" link on the ASUS U/UL Series laptop team page
For more information see

Mailing list: https://launchpad.net/~asus-ul30
Post to     : asus-ul30@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~asus-ul30
More help   : https://help.launchpad.net/ListHelp

Follow ups