← Back to team overview

banking-addons-team team mailing list archive

Re: lp:~therp-nl/banking-addons/ba61-company_awareness_bank_import_settings into lp:banking-addons

 

Review: Approve code review, no test

nitpicking (line numbers refer the to preview diff)

line 8: missing space after colon

line 29: it looks like all other methods in that file use "cr" as argument name. Time to make this one conform with the convention?

line 35-38: this is verging on abuse, IMO. I much prefer something like

if user['company_id']:
    return user['company_id'][0]
else:
    company_ids = self.pool.get('res.company').search(
                         cursor, uid, [('parent_id', '=', False)])
    return company_ids[0]

in the XML, I think using '!=' rather than '<>' is much nicer

Nothing blocking in the above. 
-- 
https://code.launchpad.net/~therp-nl/banking-addons/ba61-company_awareness_bank_import_settings/+merge/145023
Your team Banking Addons Team is subscribed to branch lp:banking-addons.


References