← Back to team overview

budgie-remix-bug-busters team mailing list archive

[Bug 1899336] Re: Thinkpad T14s (AMD) external monitors on docking station no longer detected


** Also affects: linux (Ubuntu)
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of ubuntu
budgie bug busters, which is subscribed to Ubuntu Budgie.

  Thinkpad T14s (AMD) external monitors on docking station no longer

Status in Ubuntu Budgie:
Status in linux package in Ubuntu:

Bug description:
  I run Ubuntu Budgie 20.04 on my Lenovo ThinkPad T14s with Ryzen 4750U
  processor together with the "Lenovo ThinkPad USB-C Dock (Gen 2)"

  The docking station is connected via USB-C to the system, supplies it
  with power via USB Power Delivery and provides USB 3.1 Gen 2 (10
  Gbit/s) connectivity (including an Ethernet controller and audio codec
  running over the USB data path), as well as support for two monitors
  via "DisplayPort alternate mode" of USB-C, so technically it will
  configure the four high-speed lanes of USB-C as one lane for
  SuperSpeed+ RX, one lane for SuperSpeed+ TX, and two lanes for
  DisplayPort 1.4, the latter of which the docking station will then
  demultiplex onto two full-size DisplayPort connectors like an MST hub.

  So far, external monitors have worked fine most of the time. However,
  for a couple of days now, I cannot get the system to detect the
  external monitors connected to my docking station anymore.

  The "BIOS" (EFI) boot screen (with the Lenovo logo) still shows up on
  the external monitors. However, both the LUKS/dm-crypt pre-boot-
  authentication screen (since I use full-disk-encryption) and also the
  desktop after login show up on the internal display, even with the
  laptop connected to the docking station, so it appears like the kernel
  no longer detects the monitors connecting via "DisplayPort alternate
  mode". Yesterday, I could get the monitors to show up by disconnecting
  the laptop from the docking station and reconnecting it again. Today,
  not even this appears to work. Sometimes the external monitors are
  detected (and shown as "enabled") in the display settings of Budgie,
  sometimes they do not even show up. Even when they show up and are
  enabled, nothing is displyed on them. The monitors say they do not
  receive a signal and I should check the connection. Unplugging and
  replugging the cables from the docking station to the monitors does
  not change anything.

  Audio, Ethernet and USB runs fine over the docking station, just
  DisplayPort does not. This is obviously very bad, since I now have to
  work on the internal display even with the laptop docked.

  I have the "amdgpu.exp_hw_support=1" in my kernel arguments (*) and
  the Ryzen 4000 GPU appears to be recognized.

  $ lspci -k
  06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev d1)
   Subsystem: Lenovo Renoir
   Kernel driver in use: amdgpu
   Kernel modules: amdgpu

  (*) When I installed Ubuntu Budgie 20.04, I needed to add this in
  order to extend my desktop over the two external monitors. Without
  this argument, the system only showed a single display in the
  settings, the same content was displayed on all connected monitors
  (mirrored) and there was no way to change that.

  I have attached parts of "dmesg" output which I deem relevant.

  $ uname -a
  Linux thinkpad-t14s 5.4.0-48-generic #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

To manage notifications about this bug go to: