← Back to team overview

compiz team mailing list archive

[Bug 212587] Re: Vsync setting has no effect


I have the same problem. If i use metacity only, without the advanced
compiz effects, and then enable the vsync-options in the Nvidia CP, I
get the full vsync in my videos. However, as soon as I enable compiz
again, the tearing begins. I have tried enabling vsync in compiz itself,
which indeed does help - but only for the windows on the desktop and so
on. It doesn't do much for my videos. I must say, at least for me, this
IS one of the reasons why I have to keep Windows on dualboot. If I can't
watch a movie with decent vsync or play a game on my 26" fullhd, then
why am I using it? I have tried to find ANYTHING related to this on
Google and the boards - no one seems to have a solution for this and
many who have told me not to have it, have it but don't notice it ( I
have asked for screenshots ). I agree, on a small LCD it doesn't matter
that much, but on bigger screens, my god, it's too much. My school is
planning to switch to Ubuntu BUT has a problem with this vsync bug (?).
I was the one recommending Ubuntu. Like a bunch of ppl, they want to do
more then just write text, they need good, fluid and vsync'd video
quality. This should be one of those top-ten bugs, as this affects many
areas. What good is all the extra eye candy compiz gives you, if it
tears all the time - especially with cube effects. Some told me that is
the main reason, which can't be. I have used something like compiz (and
the cube) on Windows before - not one bit of tearing. Anyway, realizing
there is a vsync-option in compiz, it should be obvious it is meant to
have it, but must be broken somehow. So, please fix this. I could get
Ubuntu on a bunch of systems around here, if this actually gets
attention and fixed.

Thank you.


Vsync setting has no effect
You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in ubuntu.