← Back to team overview

compiz team mailing list archive

[Bug 1063617] Re: 1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to wrong values


I tried this with a freshly created user account. After the first
startup ever, the settings are like this:

test@donald:~$ gsettings get org.gnome.desktop.wm.preferences auto-raise
test@donald:~$ gsettings get org.gnome.desktop.wm.keybindings lower
@as []
test@donald:~$ gsettings get org.gnome.desktop.wm.keybindings maximize
['<Super>Up', '<Primary><Super>Up', '<Primary><Alt>KP_5']
test@donald:~$ gsettings get org.gnome.desktop.wm.keybindings unmaximize
['<Super>Down', '<Alt>F5', '<Primary><Super>Down']
test@donald:~$ gsettings get org.gnome.desktop.wm.preferences focus-mode

I. e. auto-raise is correct, the "lower" keybindings is an empty array
instead of ['disabled'], and the other keys are as expected. Now I run
the "gsettings set ..." stuff as in the description. After restarting
the session, compiz does the same thing as for me: it changes the
gsettings to the values  that I showed in the description, except that
it keeps auto-raise to false.

However, what's really curious is that my originally configured
keybindings, such as Super-Down, as well as sloppy focus still actually
work, even though the current gsettings say otherwise! This is only the
case for the fresh user account, not for my real account (where the
gsettings match the actual behaviour).

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  1:0.9.8+bzr3319-0ubuntu1 regression: keeps setting gsettings keys to
  wrong values

To manage notifications about this bug go to: