← Back to team overview

compiz team mailing list archive

[Bug 782810] Re: xorg and compiz hog the cpu


No activity on this issue? This is still an issue in both 12.04 and

I have many different computers, and they all suffer from this issue!

It seems to be many different problems with compiz and resources (both
cpu and ram), that may or may not be related.  For a prolonged period,
I've noticed that compiz and xorg often takes a substantial amount of
cpu (just as for the original poster in 11.04).

There are more issues, though, that seems to be related to compiz. The
reason I'm stating this, is that they all disappeared when I changed to
ubuntu-2d on my 12.04.1 LTS desktop computer. I've seen many bug-reports
on these (and/or related) problems, but none of the fixes seems to do
anything for me. When I started using ubuntu-2d and metacity instead of
compiz, all these issues magically disappeared.

The issues I've noticed are:
* compiz and xorg taking large amount of cpu when the computer is otherwise idle (same issue as OP)
* libre office AND open office taking a large amount of cpu, when idle and just a spreadsheet opened (I've tried multiple versions of both these products, including the latest versions as of today, and both have the same issue - even when idle, it seems that one of the cpu cores is dedicated to the soffice.bin process)
* indicator-multiload takes a large amount of cpu and leaks memory (after a week of up-time, the memory usage was ridiculous - a restart would fix it though) --> note: this might be an unrelated issue since I haven't used this indicator for a while because of this problem -- now that I tried it with metacity, I noticed that the problem was gone, but that might be a coincidence.

I'm really hoping that these problems get some attention, they've
certainly been around long enough. For me, at least on my long term
desktop computer (which is already 6 years old), it has gotten so bad
that I can not use compiz anymore.

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  xorg and compiz hog the cpu

To manage notifications about this bug go to: