← Back to team overview

compiz team mailing list archive

[Bug 1131361] [NEW] Alt+Tab stopped working after upgrade to 12.10


You have been subscribed to a public bug:

I recently upgraded from PP to QQ which broke the ability to switch
between running applications by pressing Alt+Tab.

The affected host is a ThinkPad X61s. I don't know if this is of any
relevance but I think Unity/Compiz is running on/in LLVM.

Until now I tried several countermeasures in any combination imaginable
to fix this:

1. bound, unbound and rebound the Settings/Keyboard/Shortcuts/Navigation/Switch applications key over and over again
2. massive amount of reboots
3. activated, deactivated, reactivated switchers and set, unset, reset plugins and their key bindings - even other ones as Alt+Tab - in ccsm under
  3.1 Unity Plugin
  3.2 Window Mgmt - Application switcher and Static application switcher
4. deactivated Alt as a hotkey for the HUD
5. even switching keyboard layouts

It may be worth mentioning that the Alt keys themselves are working as
shown by xev. I can access the application menu, too. What makes me
wonder is the fact that I can get the HUD by tapping Alt_R but not by
pressing Alt_L (so I tried removing the HUD key binding which as stated
didn't help). App switching itself is not possible using either Alt key.

This behaviour is the same using the internal keyboard as well as a
bluetooth one.

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: bot-comment compiz keyboard shortcuts switcher unity
Alt+Tab stopped working after upgrade to 12.10
You received this bug notification because you are a member of compiz packagers, which is subscribed to compiz in Ubuntu.