← Back to team overview

compiz team mailing list archive

[Bug 455241] Re: New windows steal focus


As part of the big bug review for 16.04 LTS, I have tested this on 15.10
and the bug is still there.

** Tags added: desktop-bugscrub-triaged

** Description changed:

  Binary package hint: compiz
  In Karmic, new windows from any application are put in foreground even
  if I interact with another window before they appear.
  In gconf, I have set "focus_prevention_level" to "2", and I also tried
  setting it to "4" but it doesn't change anything.
  I tried opening gedit, then clicking on the launcher for firefox, then
  going back to gedit, and writing something. When the Firefox window
  appears, it's put in fullscreen even though I was typing in gedit. I
  also tried with other apps, and it's always the same behaviour.
+ Steps to reproduce:
+ 1. Open a lightweight application like gedit.
+ 2. Open an application that starts for a long time (GnuCash on my computer with 7 years of accouting) - may be different on your macihne
+ 3. Before the application from step 2 initializes, switch to application from step 1 and start using it (i.e. typing in gedit)
+ What happens:
+ When the application from step 2 opens, it steals focus, goes to the forground and starts receiving input that up to that point was receiving application from step 3
+ What should happen:
+ The application from step 2 should open in the background and set its status to alert (that blue triangle in the launcher in Unity).
  ProblemType: Bug
  Architecture: i386
  CompizPlugins: [core,move,resize,place,decoration,animation,ccp,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,commands,neg,video,wall,snap,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,extrawm,fade,session]
  Date: Mon Oct 19 09:48:45 2009
  DistroRelease: Ubuntu 9.10
  ExecutablePath: /usr/bin/compiz
  InterpreterPath: /bin/dash
  Package: compiz-wrapper 1:0.8.4-0ubuntu1
-  Socket 0:
-    no product info available
-  Socket 1:
-    no product info available
+  Socket 0:
+    no product info available
+  Socket 1:
+    no product info available
-  Socket 0:
-    no card
-  Socket 1:
-    no card
+  Socket 0:
+    no card
+  Socket 1:
+    no card
  PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
  ProcCmdLine: root=UUID=f9db4586-2b56-4654-98eb-8d1c24a13343 resume=UUID=ed5930f7-3c96-4098-bf91-ca487d067c14 ro quiet splash locale=fr_FR
-  LANG=fr_FR.UTF-8
-  SHELL=/bin/bash
+  LANG=fr_FR.UTF-8
+  SHELL=/bin/bash
  ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
-  xserver-xorg 1:7.4+3ubuntu5
-  libgl1-mesa-glx 7.6.0-1ubuntu4
-  libdrm2 2.4.14-1ubuntu1
-  xserver-xorg-video-intel 2:2.9.0-1ubuntu2
-  xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
+  xserver-xorg 1:7.4+3ubuntu5
+  libgl1-mesa-glx 7.6.0-1ubuntu4
+  libdrm2 2.4.14-1ubuntu1
+  xserver-xorg-video-intel 2:2.9.0-1ubuntu2
+  xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
  SourcePackage: compiz
  Uname: Linux 2.6.31-14-generic i686
  XorgConf: Error: [Errno 2] Aucun fichier ou dossier de ce type: '/etc/X11/xorg.conf'
  dmi.bios.date: 05/10/2004
  dmi.bios.vendor: Phoenix/FUJITSU
  dmi.bios.version: Version 1.26
  dmi.board.name: FJNB16C
  dmi.board.vendor: FUJITSU
  dmi.chassis.type: 10
  dmi.chassis.vendor: FUJITSU SIEMENS
  dmi.chassis.version: S6120
  dmi.modalias: dmi:bvnPhoenix/FUJITSU:bvrVersion1.26:bd05/10/2004:svnFUJITSUSIEMENS:pnLIFEBOOKS6120:pvr:rvnFUJITSU:rnFJNB16C:rvr:cvnFUJITSUSIEMENS:ct10:cvrS6120:
  dmi.product.name: LIFEBOOK S6120
  dmi.sys.vendor: FUJITSU SIEMENS
  system: distro = Ubuntu, architecture = i686, kernel = 2.6.31-14-generic

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  New windows steal focus

To manage notifications about this bug go to: