← Back to team overview

compiz team mailing list archive

[Bug 1749840] [NEW] apt-get install ubuntu-desktop doesn't work


Public bug reported:

So I used mini.iso from:


Installed a minimal ubuntu install.

sudo to root and run

apt-get install ubuntu-desktop

This is the output:

root@ubuntu:~# apt-get install ubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-desktop : Depends: unity but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

We noticed this on our foreman server today so I tried it in a minimal install from iso and it gives the same error. We suspect this was a recent change that was made.

We think there is a dependency problem with compiz-core



ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: compiz-core 1:
ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
Uname: Linux 4.4.0-112-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Thu Feb 15 18:19:15 2018
 PATH=(custom, no user)
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug xenial

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  apt-get install ubuntu-desktop doesn't work

To manage notifications about this bug go to:

Follow ups