← Back to team overview

compiz team mailing list archive

[Bug 1779925] [NEW] Compiz not running


You have been subscribed to a public bug:

To whoever reading this, I assume that you are reading the below message
after seeing the auto generated bug report. I'm just explaining below
the scenario of how and when I got the error and how it got fixed. Till
date I'm not sure what caused this error in first place.

The details of the error:

I used to get this error every time I started the system.
Report error also used to fail. Ironically now report error is working when there is no longer an error.

Coupled with this error one day my desktop user interface itself was not
working as compiz was not running.

I tried different solutions from many forums, community pages online.
But none has worked.

I had opened guest session out of curiosity to check if it works and it worked perfectly.
Then I observed a differnce and made the below change in config file ~/.config/compiz-1/compizconfig/config

profile = unity-lowgfx
## TO 
profile = unity

Then after re-start it started working. No errors since then.

P.S. Ignore if the above doesn't make any sense or it is not related the
bug report.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-130.156-generic 4.4.134
Uname: Linux 4.4.0-130-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Jul  4 00:17:09 2018
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
 ndiswrapper, 1.60, 4.4.0-122-generic, x86_64: installed
 ndiswrapper, 1.60, 4.4.0-128-generic, x86_64: installed
 ndiswrapper, 1.60, 4.4.0-130-generic, x86_64: installed
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 3rd Gen Core processor Graphics Controller [1028:0597]
InstallationDate: Installed on 2014-09-25 (1377 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: Dell Inc. Inspiron 3521
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-130-generic root=UUID=9717b719-a04b-4f40-ac66-56a9b1165260 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/20/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 06RYX8
dmi.board.vendor: Dell Inc.
dmi.board.version: A02
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A08
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd05/20/2013:svnDellInc.:pnInspiron3521:pvrA08:rvnDellInc.:rn06RYX8:rvrA02:cvnDellInc.:ct8:cvrA08:
dmi.product.name: Inspiron 3521
dmi.product.version: A08
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~16.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Tue Jul  3 21:29:09 2018
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
 product id                                 939 
 vendor                                     LGD
xserver.version: 2:1.18.4-0ubuntu0.7

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug compiz-0.9 ubuntu xenial
Compiz not running
You received this bug notification because you are a member of compiz packagers, which is subscribed to compiz in Ubuntu.