← Back to team overview

desktop-packages team mailing list archive

[Bug 1420430] Re: "Disconnect" menu item in network-manager taskbar tool is inactive when connected to network


Hi, after questions in an IRC-cannel about network-manager which only has un-clickable gray "disconnect" and "edit-Function" I tried it with my own 
                                           12.04.5 Unity Laptop. 

After I did the latest updates my network-manager also shows the pull-down-menu-switches for disconnection and for editing the settings un-clickable gray! Wifi works but is not editable.
In the Update-List I can remember to have seen          network-manager-gnome     
and 2 things hit the networkmanager begining with  lib....

** Package changed: network-manager (Ubuntu) => network-manager-applet

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to network-manager in Ubuntu.

  "Disconnect" menu item in network-manager taskbar tool is inactive
  when connected to network

Status in network-manager-applet package in Ubuntu:

Bug description:
  When connected to a network (via ethernet), I am not able to
  disconnect using the network menu in the top taskbar.  The
  "Disconnect" menu item is not highlighted.  The Connection Name is
  highlighted, but I don't need to click it because I'm already
  connected to it.  If I click the Connection Name, it connects again,
  but still does not highlight the "Disconnect" option.  So to
  disconnect, I have to go to System Settings -> Network, and click on
  the toggle.  That does work.  It's just the taskbar connection manager
  that is malfunctioning.

  I have tried restarting, and the problem persists.

  This happened after I updated software this morning using Update
  Manager.  I installed the updated Unity Greeter that puts network
  status on the login screen and updates wifi and mobile.

  I am running 12.04 LTS and Unity2d

To manage notifications about this bug go to: