← Back to team overview

desktop-packages team mailing list archive

[Bug 1431179] Re: usb_modeswitch@.service fails sometimes


FWIW: I have the same problem.

Running the usb_modeswitch_dispatcher results in the following:

/usr/sbin/usb_modeswitch_dispatcher --switch-systemd "%I"
*** buffer overflow detected ***: /usr/sbin/usb_modeswitch_dispatcher terminated
======= Backtrace: =========
======= Memory map: ========
00400000-0040a000 r-xp 00000000 fc:01 1058264                            /usr/sbin/usb_modeswitch_dispatcher
00609000-0060a000 r--p 00009000 fc:01 1058264                            /usr/sbin/usb_modeswitch_dispatcher
0060a000-0060b000 rw-p 0000a000 fc:01 1058264                            /usr/sbin/usb_modeswitch_dispatcher
01278000-01299000 rw-p 00000000 00:00 0                                  [heap]
7fbac2c7e000-7fbac2c94000 r-xp 00000000 fc:01 11796495                   /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbac2c94000-7fbac2e93000 ---p 00016000 fc:01 11796495                   /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbac2e93000-7fbac2e94000 rw-p 00015000 fc:01 11796495                   /lib/x86_64-linux-gnu/libgcc_s.so.1
7fbac2e94000-7fbac304e000 r-xp 00000000 fc:01 11800995                   /lib/x86_64-linux-gnu/libc-2.19.so
7fbac304e000-7fbac324e000 ---p 001ba000 fc:01 11800995                   /lib/x86_64-linux-gnu/libc-2.19.so
7fbac324e000-7fbac3252000 r--p 001ba000 fc:01 11800995                   /lib/x86_64-linux-gnu/libc-2.19.so
7fbac3252000-7fbac3254000 rw-p 001be000 fc:01 11800995                   /lib/x86_64-linux-gnu/libc-2.19.so
7fbac3254000-7fbac3259000 rw-p 00000000 00:00 0 
7fbac3259000-7fbac3266000 r-xp 00000000 fc:01 1057734                    /usr/lib/x86_64-linux-gnu/libpipeline.so.1.4.0
7fbac3266000-7fbac3465000 ---p 0000d000 fc:01 1057734                    /usr/lib/x86_64-linux-gnu/libpipeline.so.1.4.0
7fbac3465000-7fbac3466000 r--p 0000c000 fc:01 1057734                    /usr/lib/x86_64-linux-gnu/libpipeline.so.1.4.0
7fbac3466000-7fbac3467000 rw-p 0000d000 fc:01 1057734                    /usr/lib/x86_64-linux-gnu/libpipeline.so.1.4.0
7fbac3467000-7fbac348a000 r-xp 00000000 fc:01 11800682                   /lib/x86_64-linux-gnu/ld-2.19.so
7fbac366a000-7fbac366d000 rw-p 00000000 00:00 0 
7fbac3686000-7fbac3689000 rw-p 00000000 00:00 0 
7fbac3689000-7fbac368a000 r--p 00022000 fc:01 11800682                   /lib/x86_64-linux-gnu/ld-2.19.so
7fbac368a000-7fbac368b000 rw-p 00023000 fc:01 11800682                   /lib/x86_64-linux-gnu/ld-2.19.so
7fbac368b000-7fbac368c000 rw-p 00000000 00:00 0 
7fff2c09a000-7fff2c0bb000 rw-p 00000000 00:00 0                          [stack]
7fff2c130000-7fff2c132000 r--p 00000000 00:00 0                          [vvar]
7fff2c132000-7fff2c134000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
fish: Job 1, “/usr/sbin/usb_modeswitch_dispatcher --switch-systemd "%I"” terminated by signal SIGABRT (Abort)

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to usb-modeswitch in Ubuntu.

  usb_modeswitch@.service fails sometimes

Status in usb-modeswitch package in Ubuntu:

Bug description:
  I lack the technical knowledge to know if this is a bug in udev,
  systemd or another component.

  After the switch to systemd, my 4G Huawei USB modem  no longer
  functions as a modem unless I run usb_modeswitch to flip its state
  from USB mass storage. The command I issue and its output is below,
  which also show the Vendor and Product ID.

  Strangely, it does not do this every time. Yesterday when I updated
  using apt-get dist-upgrade upon reboot the modem worked as expected.
  But from a cold boot this morning it did not.

  $ sudo usb_modeswitch -v 0x12d1 -p 0x1f01 -J
  [sudo] password for damon: 
  Look for default devices ...
     product ID matched
   Found devices in default mode (1)
  Access device 003 on bus 003
  Current configuration number is 1
  Use interface number 0
  Use endpoints 0x01 (out) and 0x81 (in)

  USB description data (for identification)
  Manufacturer: HUAWEI Technology
       Product: HUAWEI Mobile
  Using standard Huawei switching message
  Looking for active driver ...
   OK, driver detached
  Set up interface 0
  Use endpoint 0x01 for message sending ...
  Trying to send message 1 to endpoint 0x01 ...
   OK, message successfully sent
  Reset response endpoint 0x81
   Could not reset endpoint (probably harmless): -99
  Reset message endpoint 0x01
   Could not reset endpoint (probably harmless): -99
   Device is gone, skip any further commands
  -> Run lsusb to note any changes. Bye!

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: udev 219-4ubuntu5
  ProcVersionSignature: Ubuntu 3.19.0-8.8-generic 3.19.1
  Uname: Linux 3.19.0-8-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.16.2-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  CustomUdevRuleFiles: 60-ssd-scheduler.rules
  Date: Thu Mar 12 11:37:06 2015
  InstallationDate: Installed on 2015-02-05 (34 days ago)
  InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150205)
  MachineType: LENOVO 427637U
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-8-generic root=UUID=eb18ef51-a2d0-4372-8eb9-ae009a05d4f6 ro quiet splash
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/26/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8BET62WW (1.42 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 427637U
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvr8BET62WW(1.42):bd07/26/2013:svnLENOVO:pn427637U:pvrThinkPadW520:rvnLENOVO:rn427637U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 427637U
  dmi.product.version: ThinkPad W520
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: