← Back to team overview

desktop-packages team mailing list archive

[Bug 1314549] Re: USB-headset undetected by Phonon


I have the same problem with a logitech usb headset.

It sometimes helps to disconnect the usb headset for 30 sec (dbus, phonon, udev check interval ??) . 
Then it is listed in the kmix dialog as e.g. headset #8 (it counts up the headset, although it is the same headset).  

I think, in the 14.04 release this phonon-/kde-version is buggy and changed also the behaviour of the phonon audio device handling.
=> This 30 sec check interval is not on 12.04 and the mixer of the headset comes back immediately after suspend or replug of the headset without counting up the headset label, "saying" it is a new device.

The KDE-team tried to fix the Master-Channel bugs, but introduced new
bugs and this in the end of the kde4 releases :-(

Furthermore I have to set the Master Channel again on both 12.04 and
14.04 after suspend or replug of the headset, because this never worked

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to pulseaudio in Ubuntu.

  USB-headset undetected by Phonon

Status in pulseaudio package in Ubuntu:

Bug description:
  A previously working USB-headset, which has been working flawlessly on Kubuntu 12.04 has ceased to work consistently on 14.04, whenever I try to connect it.
  While lsusb lists the device as being present and recognised, the Device Preference pane in the Audio and Video Settings of KDE keeps displaying the device in a greyed out state. In other words, it would appear that phonon thinks the device is still missing. Thus, it cannot be used.
  This problem occurs most of the times when I connect the headset to any USB port, even directly to the motherboard. Only rarely does Phonon wake up to the returned device.

  What I expected to happen was that, after the low-level handshake on the USB bus, Phonon would pop up a notification that it is switching to the headset because it´s higher on my preferences. (As it did consistently, prior to the upgrade from 12.04.)
  Instead, there is no announcement whatsoever. Also, the Select Master Channel window of KMix does not list the headset.

  I am running Kubuntu 14.04 LTS.
  The package is version 4:4.13.0-0ubuntu1, which is the current package available from the repositories.
  Please note that I am not entirely sure at this time wether kde-runtime is the correct package.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: kde-runtime 4:4.13.0-0ubuntu1
  ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
  Uname: Linux 3.13.0-24-generic x86_64
  NonfreeKernelModules: nvidia zfs zunicode zavl zcommon znvpair
  ApportVersion: 2.14.1-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Wed Apr 30 10:58:25 2014
  ExecutablePath: /usr/bin/kcmshell4
  InstallationDate: Installed on 2014-04-24 (5 days ago)
  InstallationMedia: Kubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140205)
   PATH=(custom, no user)
  SourcePackage: kde-runtime
  UpgradeStatus: Upgraded to trusty on 2014-04-27 (2 days ago)

To manage notifications about this bug go to: