← Back to team overview

desktop-packages team mailing list archive

[Bug 1442428] Re: Headphones not detected after fresh boot or suspend/resume cycle, until unplugged and plugged back in


Thanks Raymond. I think I got some interesting results.

I ran hdajacksensetest and amixer -c0 contents after a fresh boot (when
my headphones were not detected) and ran them again after unplugging and
plugging my headphones back in.

hdajacksensetest gave the same result for both tests:

Pin 0x24 (Green Line Out, Rear side): present = Yes
Pin 0x25 (Black Line Out, Rear side): present = No
Pin 0x26 (Orange Line Out, Rear side): present = No
Pin 0x27 (Grey Line Out, Rear side): present = No
Pin 0x28 (Green Headphone, Front side): present = Yes
Pin 0x29 (Pink Mic, Front side): present = No
Pin 0x2a (Blue Line In, Rear side): present = No
Pin 0x2b (Pink Mic, Rear side): present = No

The amixer output changed after unplugging and plugging the headphones
back in. I've attached text files showing the before/after output.

** Attachment added: "Output of "amixer -c0 contents" after (1) a fresh boot, and (2) unplugging and plugging headphones back in"

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to alsa-driver in Ubuntu.

  Headphones not detected after fresh boot or suspend/resume cycle,
  until unplugged and plugged back in

Status in alsa-driver package in Ubuntu:

Bug description:
  This is a regression from Ubuntu 14.04 (I have not tested 14.10).

  Headphones which were already plugged in prior to a suspend/resume
  cycle or a shutdown/reboot are not detected after a power-on (i.e.,
  "Headphones: Built-in Audio" is absent from the "Output" tab in the
  Sound Settings). Unplugging the headphones and plugging them back in
  results in the headphones being detected and automatically selected.

  I used the ubuntu-bug tool to submit this bug report after a fresh
  boot, and after going through the troubleshooting steps (which
  unsuccessfully attempted to play some tones through the headphone
  jack), "Headphones" showed up in the Output tab (without me having to
  unplug them and plug them in again), but was not automatically
  selected ("Line Out" is selected by default). Manually selecting
  "Headphones" succeeded in enabling sound on the headphones. So it
  appears that perhaps pulseaudio does not automatically check for the
  presence of headphones upon boot or resume from suspend (or maybe it
  does, but the hardware isn't ready to respond at the time).

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu4
  ProcVersionSignature: Ubuntu 3.19.0-13.13~pre201504091631-generic 3.19.3
  Uname: Linux 3.19.0-13-generic x86_64
  ApportVersion: 2.17-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC1:  furkan     2171 F.... pulseaudio
   /dev/snd/controlC0:  furkan     2171 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Thu Apr  9 20:45:11 2015
  InstallationDate: Installed on 2014-06-06 (307 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:SB failed
  Symptom_Card: Built-in Audio - HDA ATI SB
   /dev/snd/controlC1:  furkan     2171 F.... pulseaudio
   /dev/snd/controlC0:  furkan     2171 F.... pulseaudio
  Symptom_Jack: Green Headphone Out, Front
  Symptom_Type: No sound at all
  Title: [GA-970A-D3, VIA VT2020, Green Headphone Out, Front] No sound at all
  UpgradeStatus: Upgraded to vivid on 2015-03-27 (13 days ago)
  dmi.bios.date: 12/16/2013
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F13b
  dmi.board.name: GA-970A-D3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF13b:bd12/16/2013:svnGigabyteTechnologyCo.,Ltd.:pnGA-970A-D3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-970A-D3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-970A-D3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: