← Back to team overview

desktop-packages team mailing list archive

[Bug 883319] Re: xrandr --scale restricts area in which mouse moves


Has this patch been applied to any of the newer versions of xorg? I'm
having a hell of a time getting this patched and would rather just
upgrade xorg completely.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.

  xrandr --scale restricts area in which mouse moves

Status in X.Org X server:
Status in xorg-server package in Ubuntu:
  Fix Released
Status in xorg-server source package in Precise:
  Fix Released
Status in xorg-server source package in Quantal:
  Fix Released
Status in xorg-server source package in Raring:
  Fix Released

Bug description:
  SRU Request:

  A bug in the version of xorg-server in precise prevents users from scaling screen resolution. When attempting to do so, as was possible in Natty and earlier, and which is possible in Quantal+, the mouse pointer remains locked inside the old resolution. This prevents users of small screens such as netbooks from scaling to a greater screen resolution.

  [Test Case]
  - On a netbook with intel chipset, such as a Dell Mini 9 or 10, scale the display by using the following command:

  xrandr --output LVDS1 --panning 1280x750 --scale 1.25x1.25

  See if the mouse moves correctly to all screen extremities, and is not
  confined by a transparent border at 1024x600

  [Regression Potential]
  This is fixed with a patch backported from the xorg-server version in Quantal. In theory it should just affect screen which are scaled and panned, which is uncommon. If so, the patch can be backed out.

  Original Bug Description:
  in kubuntu (and ubuntu) 11.04 i used to enlarge my laptop screen like so

  xrandr --output LVDS1 --scale 1.2x1.2

  this worked fine: the desktop scaled to larger size correctly .
   After upgrading to 11.10, in kde the desktop still resizes
  correctly, but the movement of the mouse is restricted to an area equal to
  the screen size *before* issuing the scaling command. .. Ie let's say
  the mode is 1366x768 and I do xrandr --output LVDS1 --scale 1.2x1.2 the
  screen size changes to 1640x922 but the mouse moves in an area the size of
  1366x768 in the top left of the screen and then 'hits a wall' preventing
  it to move. I also tried ubuntu 11.10 with gnome: here the screen also
  resizes, but I have the same issue with the mouse, and the extended area
  of the desktop is black...

  Some time ago there was a similar issue, which was resolved later. Now it seems
  to be back...

  jos@samsungsucks:~$ lsb_release -rd
  Description:    Ubuntu 11.10
  Release:        11.10

  jos@samsungsucks:~$ xrandr --version
  xrandr program version       1.3.5
  Server reports RandR version 1.3

To manage notifications about this bug go to: