← Back to team overview

desktop-packages team mailing list archive

[Bug 926917] Re: Mouse wheel tilt not works


I have attached a USB Capture file (standard pcapng format, can open in wireshark or so) of the mouse doing:
Packets  -  Physical Action Taken
1-6  -  Capture stream setup
7-16  -  Pressing left-tilt quickly (it seems to repeat it while being pressed)
17-20  -  Pressing left-tilt as quick as I can (it seems to repeat it while being pressed)
21-22  -  Mousewheel scrolled up one tick
23-24  -  Mousewheel scrolled down one tick
This was while using the Razer Naga 2014 mouse.  As you can see the data coming from the USB device is significantly different between tilting and the mousewheel usages.  The tilt works properly in Windows and is seen as a left/right tilt in various applications such as multiple web browsers.  In ubuntu, however, it it sending more mousewheel signals and the Fedora project seems to have fixed it via "Map REL_DIAL to horizontal scrolling (bfdo#73105, rhbz#869065)", though I am unable to confirm due to not having Fedora installed anywhere, may see if they have a livecd version of their system as well when I get time later.

** Attachment added: "USB Packet Capture File"

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-input-evdev in Ubuntu.

  Mouse wheel tilt not works

Status in xserver-xorg-input-evdev package in Ubuntu:

Bug description:
  Ubuntu 12.04After updating the xserver-xorg-input-evdev package from 2.6.0-1ubuntu13 to
  the Microsoft Wireless Laser Mouse 8000 wheel tilt works like scrolling and the xev utility  reports that buttons 4 and 5 clicked when I try to tilt the wheel left and right (should report 6 and 7 buttons for the tilt, 4 and 5 for wheel scroll). 
  It worked right before the update.

To manage notifications about this bug go to: