← Back to team overview

desktop-packages team mailing list archive

[Bug 1466934] Re: Trying to maximize battery life on HP dv7-4272us


foobar, thank you for reporting this and helping make Ubuntu better.
Examining the information you have given us, this does not appear to be
a bug report so we are closing it. We understand the difficulties you
are facing, but it is better to raise problems and general inquiries you
are having in the support tracker at
https://answers.launchpad.net/ubuntu if you are uncertain if they are
software bugs. You can also find help with your problem in the support
forum of your local Ubuntu community http://loco.ubuntu.com/ or asking
at http://askubuntu.com or http://ubuntuforums.org. For help on
reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

** Tags added: latest-bios-f.29

** Changed in: xorg (Ubuntu)
       Status: New => Invalid

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Trying to maximize battery life on HP dv7-4272us

Status in xorg package in Ubuntu:

Bug description:
  This AMD 3-core + Radeon runs really hot, and I'm trying to maximize
  battery life.

  When I try radeon.dpm=1, I get display glitching every few seconds
  when the dpm switches displays.  I haven't found any way to force dpm
  to keep the discrete display completely turned off, both to save power
  and to stop the glitching.

  Among other problems, the mere existence of HDMI audio keeps waking up
  the discrete GPU, both wasting power & glitching the display.  So I
  tried radeon.audio=0.  I don't think it helps, but I left it in.

  The only way to really kill the HDMI audio problems is to blacklist
  snd_hda_intel, but that kills _all_ of my audio (except Bluetooth
  audio).  So I had to un-blacklist snd_hda_intel.

  So I'm using radeon.dpm=0.

  If radeon.runpm=1, I still get problems.

  So I'm using radeon.runpm=0.

  This works pretty well; I've gotten the temperature down to 68 degrees
  or so, but this is still too hot.

  If I turn off the discrete graphics completely using

  echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

  this works quite well -- I can get the temperature down to 64 degrees
  or so -- but now my log fills up with complaints that my radeon
  discrete driver isn't turned on.  (I'll send you another report
  showing you this.)

  I want to be able to operate this HP laptop in the most power-saving
  way -- by completely turning off the discrete radeon GPU.

  Could you provide any suggestions about how to do this?

  Thanks very much.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: xorg 1:7.7+7ubuntu4
  ProcVersionSignature: Ubuntu 3.19.0-21.21-generic 3.19.8
  Uname: Linux 3.19.0-21-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Fri Jun 19 09:31:02 2015
  DistUpgraded: Fresh install
  DistroCodename: vivid
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
   Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] [1002:9712] (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company Device [103c:1641]
   Advanced Micro Devices, Inc. [AMD/ATI] Robson CE [Radeon HD 6370M/7370M] [1002:68e4] (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company Radeon HD 6370M [103c:1641]
  InstallationDate: Installed on 2015-06-06 (13 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-21-generic root=UUID=0a49d103-e2eb-4b21-a433-c41a1ef8d27b ro quiet splash radeon.runpm=0 radeon.dpm=0 radeon.audio=0 radeon.pcie_gen2=0 acpiphp.disable=1 vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/25/2013
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: F.29
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 1641
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 67.33
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnHewlett-Packard:bvrF.29:bd02/25/2013:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvr0583120000242B20000620100:rvnHewlett-Packard:rn1641:rvr67.33:cvnHewlett-Packard:ct10:cvrN/A:
  dmi.product.name: HP Pavilion dv7 Notebook PC
  dmi.product.version: 0583120000242B20000620100
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.60-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.2-0ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.2-0ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
  xserver.bootTime: Fri Jun 19 09:08:20 2015
  xserver.configfile: default
  xserver.errors: RADEON(G0): [XvMC] Failed to initialize extension.
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.17.1-0ubuntu3
  xserver.video_driver: radeon

To manage notifications about this bug go to: