← Back to team overview

desktop-packages team mailing list archive

[Bug 1480590] Re: Minecraft + Oracle Java always crashes with SIGSEGV (ubuntu 14.04, java 7.0_80-b15, minecraft 1.7.10)


Tried changing to latest nvidia open source drivers (version 355.06 from
nvidia-355). It did not prevent a crash.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Minecraft + Oracle Java always crashes with SIGSEGV (ubuntu 14.04,
  java 7.0_80-b15, minecraft 1.7.10)

Status in xorg package in Ubuntu:

Bug description:
  lsb_release -rd
  Description:	Ubuntu 14.04.2 LTS
  Release:	14.04

  java -version
  java version "1.7.0_80"
  Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
  Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)

  apt-cache policy xorg
    Installed: 1:7.7+1ubuntu8.1
    Candidate: 1:7.7+1ubuntu8.1
    Version table:
   *** 1:7.7+1ubuntu8.1 0
          500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
          100 /var/lib/dpkg/status
       1:7.7+1ubuntu8 0
          500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

  Minecraft 1.7.10

  I tried playing Minecraft (a game) but it always crashes after a few minutes (5-20 minutes) with the same kind of crash.
  Minecraft worked previously on this computer, a few months ago.

  Steps to reproduce:
  1. Start Minecraft.
  2. Press single player.
  3. Create a new world or load an old world.
  4. Press escape to view menu.
  5. Maximize the window that Minecraft is running in.
  6. Wait for 5-20 minutes until crash (always crashes).

  What has changed and not changed:
  Regular ubuntu updates.
  Probably linux kernel update
  Probably updated java.
  Same version of minecraft.
  Probably updated/changed graphics driver.

  relevant Minecraft game output:
  Failed to open BO for returned DRI2 buffer (1855x1056, dri2 back buffer, named 93).
  This is likely a bug in the X Server that will lead to a crash soon.
  # A fatal error has been detected by the Java Runtime Environment:
  #  SIGSEGV (0xb) at pc=0x00007f7cc4a9e51f, pid=4648, tid=140175230424832
  # JRE version: Java(TM) SE Runtime Environment (7.0_80-b15) (build 1.7.0_80-b15)
  # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.80-b11 mixed mode linux-amd64 compressed oops)
  # Problematic frame:
  # C  [i965_dri.so+0x3a851f]  __driDriverGetExtensions_i915+0xa526f
  # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
  # An error report file with more information is saved as:
  # /home/meb1/.minecraft/hs_err_pid4648.log
  # If you would like to submit a bug report, please visit:
  #   http://bugreport.java.com/bugreport/crash.jsp
  # The crash happened outside the Java Virtual Machine in native code.
  # See problematic frame for where to report the bug.

  Speculation about possible cause:
  Bug in latest oracle java.
  Linux kernel bug (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1478989)
  Bug in x-server.
  Graphics driver bug (http://www.minecraftforum.net/forums/support/unmodified-minecraft-client/2466332-arch-linux-failed-to-open-bo-for-returned-dri2).

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8.1
  ProcVersionSignature: Ubuntu 3.13.0-61.100-generic 3.13.11-ckt22
  Uname: Linux 3.13.0-61-generic x86_64

  ApportVersion: 2.14.1-0ubuntu3.11
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sat Aug  1 19:50:06 2015
  DistUpgraded: Fresh install
  DistroCodename: trusty
  DistroVariant: ubuntu
   Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
     Subsystem: CLEVO/KAPOK Computer Device [1558:2300]
  InstallationDate: Installed on 2014-06-11 (415 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: Notebook W230SS
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-61-generic root=UUID=93c74f51-3b61-4655-ac70-3bb96879f01f ro quiet splash
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/15/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 4.6.5
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: W230SS
  dmi.board.vendor: Notebook
  dmi.board.version: Not Applicable
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: Notebook
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd04/15/2014:svnNotebook:pnW230SS:pvrNotApplicable:rvnNotebook:rnW230SS:rvrNotApplicable:cvnNotebook:ct9:cvrN/A:
  dmi.product.name: W230SS
  dmi.product.version: Not Applicable
  dmi.sys.vendor: Notebook
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.62+git20150703.676c806d-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.6.3~git20150727+10.6.ccef8901-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.6.3~git20150727+10.6.ccef8901-0ubuntu0ricotz~trusty
  version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.99+git20140806.fbf575cb-0ubuntu0sarvatt~trusty
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150729.4246c633-0ubuntu0sarvatt~trusty
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11+git20141030.3fb97d78-0ubuntu0sarvatt~trusty2
  xserver.bootTime: Sat Aug  1 18:37:08 2015
  xserver.configfile: default
   open /dev/dri/card0: No such file or directory
   intel: Failed to load module "present" (module does not exist, 0)
  xserver.logfile: /var/log/Xorg.0.log
   product id                                4931
   vendor                                     CMN
  xserver.version: 2:1.15.1-0ubuntu2.7

To manage notifications about this bug go to: