← Back to team overview

desktop-packages team mailing list archive

[Bug 1492767] Re: gdk-pixbuf packages update breaks the GUI in Trusty 14.04.3


It had seemed pretty bad, and I was in a wonder how something such as
that can even happen, so I tried to reproduce it by installing the same
ISO/Version in Virtualbox, and could not even reproduce it myself.

There is still the error message at post install, but it does not affect
the GUI in any way. I installed twice in a row in Virtualbox to be sure
of the result and each time after updating, I didn't get the GUI to go
wrong as it happened in that laptop.

So this bug report can be put aside, unless something new comes out with

Best regards,

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gdk-pixbuf in Ubuntu.

  gdk-pixbuf packages update breaks the GUI in Trusty 14.04.3

Status in gdk-pixbuf package in Ubuntu:

Bug description:

  I did a fresh install with a Trusty 14.04.3 (x86_64) yesterday (custom
  Bento Openbox), and today, I updated the system (with the console,
  because other issues came first which led me to do a filesystem
  check). Then I started Synaptic, and oops! no GUI, only the borders of
  the window would show. Several other programs were affected and would
  not start (Geany, text editor), or show their content. After tests and
  research it appeared only GTK3 programs were affected. If using a
  theme with GTK2, or move the GTK configuration out of the way, the
  programs would work.

  The upgrade contained the following packages:

  I fixed the issue by booting to the Live USB I had used to install,
  and repackage the programs with dpkg-repack, then reinstalled them
  using "sudo dpkg -i *.deb". (copied from the live usb to the home in
  the install, rebooted and reinstalled there).

  Problem solved for this install, where I have for now blocked the
  update for these three packages.

  At post-install, after I had updated, I had the same message as the people who reported that bug:

  (gtk-update-icon-cache-3.0:29671): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

  This likely means that your installation is broken.
  Try running the command
    gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
  to make things work again for the time being.

  and when trying to do so, the console returned a message stating gdk-
  pixbuf-query-loaders was not installed. (no such package in the repos

  More information can be found at

  where I discussed about this bug and my findings.

  Now I will try to produce this bug again in the Live USB (which has no

  Best regards,

To manage notifications about this bug go to: