← Back to team overview

desktop-packages team mailing list archive

[Bug 1492934] Re: Kernel sometimes won't boot to login screen


Launchpad has imported 8 comments from the remote bug at

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at

On 2015-06-28T19:17:14+00:00 Rémi Verschelde wrote:

+++ This bug was initially created as a clone of Bug 15734 comment 39

I tried to install Mageia 5 on my new laptop (UEFI) an ASUS N551J with
two graphical cards (intel and nvidia). I have tried every option
mentioned in the errata (hybrid graphics). I have tried the Live KDE 64
DVD and the classical 64 DVD. Nothing works. I am now 'doomed' to use
Mint, that works at once, but I like Mageia much better (if it is


Sometimes at boottime (LiveDVD) I get many nouveau errors and after a
while I get a KDE desktop (intel detected?). I can than install it and
after reboot I sometimes can configure a user and can log in into KDE.
After a few seconds everything freezes. Poweroff and poweron and than it
freezes already at boottime (blank screen or with nouveau errors with
sometimes I see kernel panic).

Sometimes at boottime (LiveDVD) I get less nouveau errors and it freezes
already (no KDE).

I tried boot options as suggested 'optimus' and/or 'rd.blacklist=nouveau
rd.blacklist=nvidia xdriver=intel' –> No effect. Still nouveau errors at
boottime and/or freezes.


Installation works until after reboot. Same problems as with the LiveDVD.
I tried the boot options, no effect. At the point of the installer to configure the graphics, it suggested 'Intel 810 and later' and not 'use intel only' as told in the errata. Even with Intel selected I get nouveau errors at boottime, with or without boot options.

It seems a problem like mentioned in the errata with the hybrid graphics
(Intel+Nvidia), but the suggested options does not work.

Linux Mint 17.1:

No problem, works at once. No errors.

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-06-28T19:18:29+00:00 Rémi Verschelde wrote:

Please also refer to:

attachment 6786 boot screen LiveKDE64DVD on ASUS N551J nouveau errors

attachment 6787 boot screen LiveKDE64DVD on ASUS N551J nouveau errors

attachment 6788 Xorg log of LiveKDE64DVD on ASUS N551J (if I am lucky to
get so far)

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-06-28T20:52:57+00:00 Isis2000 wrote:

Same issues on my new laptop:

4th Gen Core Processor Integrated Graphics Controller
GeForce GTX 850M

Went back to Mageia 4, no issues there, as there never were.

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-06-28T21:08:01+00:00 Mageia-g wrote:

A quick search found this:


My recollection is that using rd.blacklist didn't work for me, because
the nouveau driver got loaded later in the boot sequence. You could try

  blacklist nouveau

to /etc/modprobe.conf on the installed system to see if that helps.

I see in Peter's log that he is also experiencing bug 16033, although
that is probably not important at this stage.

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-06-28T21:58:49+00:00 Mageia-g wrote:

Just done some experiments on my laptop, and I need both the boot option
*and* the entry in /etc/modprobe.conf to prevent the nouveau module
being loaded.

Furthermore, the required boot option is "rdblacklist=nouveau", not

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-06-29T20:08:07+00:00 Info4pwo wrote:

It is working now :-)

I use the boot options 'rdblacklist=nouveau nouveau.runpm=0

nouveau.runpm=0 is a tip from doktor500, with this the LiveDVD/USB gives
nouveau errors but I get at least at every boot a KDE desktop.

The same boot options I use for the installed system.
Right after install with the first boot I selected 'Safe Mode' and added 'blacklist nouveau' to /etc/modprobe.conf.

After this I get no errors and get a beautiful Mageia KDE desktop.

Thanks for all the help.

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-07-04T14:38:20+00:00 Isis2000 wrote:

Same here.
Installed Mageia 5 in a free partition, so i could leave Mageia 4 in place, in case of.

But, so far the abovementioned workaround worked.

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

On 2015-09-06T16:59:11+00:00 Anaselli wrote:

Acer aspire 5750g installed on external usb3.0 disk, same problem here
black listed nouveau workarounded here also

Reply at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-

** Changed in: xserver-xorg-video-nouveau (Mandriva)
       Status: Unknown => Confirmed

** Changed in: xserver-xorg-video-nouveau (Mandriva)
   Importance: Unknown => Critical

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-nouveau in Ubuntu.

  Kernel sometimes won't boot to login screen

Status in xserver-xorg-video-nouveau package in Ubuntu:
Status in xserver-xorg-video-nouveau package in Mandriva:

Bug description:
  I'm using 3.19.0-26-generic as kernel.

  Ubuntu version is:
  Description:	Ubuntu 15.04
  Release:	15.04

  Version of the nouveau driver is:
    Installed: 1:1.0.11-1ubuntu2build1
    Candidate:    1:1.0.11-1ubuntu2build1
    Version table:
   *** 1:1.0.11-1ubuntu2build1 0
          500 http://ftp.acc.umu.se/ubuntu/ vivid/main amd64 Packages
          100 /var/lib/dpkg/status

  I expected the module to be able to work without freezing the entire system.
  This issue prevents me from getting to the login session.

  I have installed Ubuntu on my brand new laptop which is a Asus N550JK.
  It has Hybrid Graphics (Intel 4th Generation + nVidia GeForce GTX 850M so I was told to nvidia-prime for Optimus.
  Sometimes when I boot the kernel it stops before I see the login window and the computer is completely frozen.

  However if I switch to the proprietary driver for nouveau the computer
  doesn't lock completely anymore.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
  ProcVersionSignature: Ubuntu 3.19.0-26.28-generic 3.19.8-ckt4
  Uname: Linux 3.19.0-26-generic x86_64
  NonfreeKernelModules: nvidia
  .proc.driver.nvidia.registry: Binary: ""
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  346.59  Tue Mar 31 14:10:31 PDT 2015
   GCC version:  gcc version 4.9.2 (Ubuntu 4.9.2-10ubuntu13)
  ApportVersion: 2.17.2-0ubuntu1.3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Mon Sep  7 09:19:38 2015
  DistUpgraded: Fresh install
  DistroCodename: vivid
  DistroVariant: ubuntu
   bbswitch, 0.7, 3.19.0-26-generic, x86_64: installed
   nvidia-346, 346.59, 3.19.0-26-generic, x86_64: installed
   Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:11cd]
     Subsystem: ASUSTeK Computer Inc. Device [1043:11cd]
  InstallationDate: Installed on 2015-09-05 (1 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-26-generic.efi.signed root=UUID=28c2cc37-e8b5-4f1d-8a4a-33f26e77b390 ro quiet splash vt.handoff=7
  SourcePackage: xserver-xorg-video-nouveau
  UdevLog: Error: [Errno 2] Filen eller katalogen finns inte: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/26/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: N550JK.208
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: N550JK
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN550JK.208:bd09/26/2014:svnASUSTeKCOMPUTERINC.:pnN550JK:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN550JK:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: N550JK
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.60-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.9-2ubuntu1~vivid2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.9-2ubuntu1~vivid2
  version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
  xserver.bootTime: Mon Sep  7 09:16:28 2015
  xserver.configfile: /etc/X11/xorg.conf
   intel(G1): [drm] failed to set drm interface version: Permission denied [13].
   intel(G1): Failed to claim DRM device.
  xserver.logfile: /var/log/Xorg.0.log
   product id                               16971 
   vendor                                     SDC
  xserver.version: 2:1.17.1-0ubuntu3

To manage notifications about this bug go to: