← Back to team overview

desktop-packages team mailing list archive

[Bug 1175705] Re: Xorg freeze


ar, thank you for reporting this bug to Ubuntu. Raring reached EOL on January 27, 2014.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

If this is reproducible in a supported release, please file a new

** Changed in: xserver-xorg-video-ati (Ubuntu)
       Status: New => Invalid

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-ati in Ubuntu.

  Xorg freeze

Status in xserver-xorg-video-ati package in Ubuntu:

Bug description:
  After the upgrade to 13.04 it worked fine. But after some restarts
  unity is not shown. Logon works perfect, but changing to unity
  workplace give a white flash and a dark screen.

  I dit use the recovery boot options, reinstalled ati en radeon and it
  worked again. On the next reboot again a black sreen.

  Installed a vesa driver in xorg.conf>
  Section "Device"
  	Identifier	"Configured Video Device"

  Section "Monitor"
  	Identifier	"Configured Monitor"
  	HorizSync	30.0-62.0
  	VertRefresh	50.0-70.0

  Section "Screen"
  	Identifier	"Default Screen"
  	Monitor		"Configured Monitor"
  	Device		"Configured Video Device"
  	DefaultDepth	24
      Subsection "Display"
          Depth       24
          Modes       "1366x768" "1024x768" "800x600" 

  No luck. Problems remains. So no flrx, no radeon, no vesa drivers that
  work for this mobilty 4250 chipset.

  Systeem works in recovery mode, chossing resume, but gives a wrong
  screensize and distored fonts.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: xorg 1:7.7+1ubuntu4
  ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
  Uname: Linux 3.8.0-19-generic x86_64
  ApportVersion: 2.9.2-0ubuntu8
  Architecture: amd64
  CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,mousepoll,regex,move,wall,animation,gnomecompat,snap,grid,place,workarounds,imgpng,vpswitch,fade,session,scale,expo,unitymtgrabhandles,ezoom,unityshell]
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Thu May  2 19:38:57 2013
  DistUpgraded: 2013-04-29 13:36:24,164 DEBUG enabling apt cron job
  DistroCodename: raring
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Within the last few days
   Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4225/4250] [1002:9712] (prog-if 00 [VGA controller])
     Subsystem: Lenovo Device [17aa:21b8]
  InstallationDate: Installed on 2011-02-10 (811 days ago)
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
  MachineType: LENOVO 030247G
  MarkForUpload: True
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=2d744989-765f-4da6-baed-3ccd4299bb1b ro recovery nomodeset
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: Upgraded to raring on 2013-04-29 (3 days ago)
  dmi.bios.date: 01/07/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 82ET63WW (2.04 )
  dmi.board.name: 030247G
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvr82ET63WW(2.04):bd01/07/2011:svnLENOVO:pn030247G:pvrThinkPadEdge:rvnLENOVO:rn030247G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 030247G
  dmi.product.version: ThinkPad Edge
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
  version.ia32-libs: ia32-libs 20090808ubuntu36
  version.libdrm2: libdrm2 2.4.43-0ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
  version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
  xserver.bootTime: Thu May  2 19:37:41 2013
  xserver.configfile: /etc/X11/xorg.conf
   open /dev/fb0: No such file or directory
   Screen 0 deleted because of no matching config section.
   Screen 0 deleted because of no matching config section.
   Screen 0 deleted because of no matching config section.
   Screen 0 deleted because of no matching config section.
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.13.3-0ubuntu6

To manage notifications about this bug go to: