← Back to team overview

desktop-packages team mailing list archive

[Bug 1500216] Re: Installing/Updating language support failed with "org.freedesktop.DBus.Error.NoReply" message


Unfortunately terminal had zero output during the execution of command
(gnome-language-selector) ,  despite that the error message appeared.

See attached screenshot3

I had some output in keyboard interrupt (Ctrl+C) but I'm not sure if
it's relevant with the error message.

Traceback (most recent call last):
  File "/usr/bin/gnome-language-selector", line 22, in on_activate
  File "/usr/lib/python3/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 246, in __init__
  File "/usr/lib/python3/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 697, in verifyInstalledLangPacks
    self.commit(missing, [])
  File "/usr/lib/python3/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 633, in commit_aptdaemon
  File "/usr/lib/python3/dist-packages/LanguageSelector/gtk/GtkLanguageSelector.py", line 599, in _wait_for_aptdaemon_finish

I have also tried

$ unity-control-center -v

but no helpful output neither (I guess)

unity-control-center -v 
** (unity-control-center:8377): DEBUG: Enabling debugging
(gnome-language-selector:8384): Gtk-DEBUG: Connecting to session manager

I have the proposed repositories enabled (always in development branches) and the system is up-to-date. 


** Attachment added: "screenshot3"

** Changed in: language-selector (Ubuntu)
       Status: Incomplete => New

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to language-selector in Ubuntu.

  Installing/Updating language support failed with
  "org.freedesktop.DBus.Error.NoReply" message

Status in language-selector package in Ubuntu:

Bug description:
  Trying to add another language as the default in the system, indicates the message that "Language support is not installed completely" [screenshot1]. 
  That's an ordinary message. 

  When I'm clicking the "Install" button I get an error [screenshot2].

  From this point and after, I cannot call back the Language Support
  menu. It does not open at all.

  It will open if I restart the session and it will fail again with the
  same error message.

  $ sudo service lightdm restart

  The "workaround" to alter the system language is to click the "Remind
  me later" button instead of "Install".

  How to reproduce.

  1) Open the Language Support 
  2) Where the message window indicates that "Language support is not installed completely" [screenshot1] hit the "Install" button. 

  This bug has been filled manually, as I cannot find any crash report
  in /var/crash/ folder.


  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: unity-control-center 15.04.0+15.10.20150923-0ubuntu1
  ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
  Uname: Linux 4.2.0-11-generic x86_64
  ApportVersion: 2.19-0ubuntu1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Sep 27 17:37:15 2015
  InstallationDate: Installed on 2015-09-09 (18 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150908)
  SourcePackage: unity-control-center
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: