← Back to team overview

desktop-packages team mailing list archive

[Bug 1424059] Re: libosmesa6 conflicts with libglapi-mesa-lts-*


Hello Doug, or anyone else affected,

Accepted mesa into trusty-proposed. The package will build now and be
available at https://launchpad.net/ubuntu/+source/mesa/10.1.3-0ubuntu0.5
in a few hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in

** Changed in: mesa (Ubuntu Trusty)
       Status: In Progress => Fix Committed

** Tags added: verification-needed

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to mesa in Ubuntu.

  libosmesa6 conflicts with libglapi-mesa-lts-*

Status in mesa package in Ubuntu:
Status in mesa source package in Trusty:
  Fix Committed

Bug description:
  libosmesa6 10.1.3-0ubuntu0.3 amd64 can't be installed because it depends on libglapi-mesa (= 10.1.3-0ubuntu0.3), but libglapi-mesa-lts-utopic 10.3.2-0ubuntu1~trusty2 amd64 is '10.3.2-0ubuntu1' not '10.1.3-0ubuntu0.3'.

  [Test Case]
  >sudo aptitude install libosmesa6
  The following NEW packages will be installed:
    libglapi-mesa{a} libosmesa6
  0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
  Need to get 1,009 kB of archives. After unpacking 3,682 kB will be used.
  The following packages have unmet dependencies:
   xserver-xorg-lts-utopic : Conflicts: libglapi-mesa (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
   libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa but 10.1.3-0ubuntu0.3 is to be installed.

  [Possible solution]
  Include utopic's libosmesa(-dev) in the LTS enablement stack, so versions match.

  [Reverse dependencies]
  wine recommends libosmesa6

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: libglapi-mesa-lts-utopic 10.3.2-0ubuntu1~trusty2
  ProcVersionSignature: Ubuntu 3.16.0-31.41~14.04.1-generic 3.16.7-ckt5
  Uname: Linux 3.16.0-31-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.7
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Fri Feb 20 15:45:52 2015
   gcc-4.9-base 4.9.1-0ubuntu1
   libc6 2.19-0ubuntu6.5
   libgcc1 1:4.9.1-0ubuntu1
   multiarch-support 2.19-0ubuntu6.5
  InstallationDate: Installed on 2015-02-08 (12 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150203.2)
  SourcePackage: mesa-lts-utopic
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: