← Back to team overview

desktop-packages team mailing list archive

[Bug 474714] Re: pulseaudio not working


I think I have a similar issue, but I couldn't solve it.
In my case I  upgraded pulseaudio manually from 4.0 to 7.0, since yesterday everytime I plug in some headphones (bluetooth ones or not) the sound goes weird like scratchy..
So, please help me!
Here's my output when I type:
$pulseaudio -v
pulseaudio: relocation error: pulseaudio: symbol pa_sample_rate_valid, version PULSE_0 not defined in file libpulse.so.0 with link time reference
$which pulseaudio
$ldd `which pulseaudio`
	linux-vdso.so.1 =>  (0x00007ffe99a82000)
	libpulsecore-7.0.so => /usr/lib/libpulsecore-7.0.so (0x00007f031de2e000)
	libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f031dbe5000)
	libpulsecommon-7.0.so => /usr/lib/pulseaudio/libpulsecommon-7.0.so (0x00007f031d976000)
	libltdl.so.7 => /usr/lib/x86_64-linux-gnu/libltdl.so.7 (0x00007f031d76c000)
	libcap.so.2 => /lib/x86_64-linux-gnu/libcap.so.2 (0x00007f031d567000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f031d348000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f031d144000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f031cd7f000)
	libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f031cb16000)
	libspeexdsp.so.1 => /usr/lib/x86_64-linux-gnu/libspeexdsp.so.1 (0x00007f031c903000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f031c5fd000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f031e0e0000)
	libjson-c.so.2 => /lib/x86_64-linux-gnu/libjson-c.so.2 (0x00007f031c3f1000)
	libpulsecommon-4.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-4.0.so (0x00007f031c18a000)
	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f031bf45000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f031bd3c000)
	libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f031bb0b000)
	libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f031b63b000)
	libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f031b40e000)
	libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f031b205000)
	libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f031afe5000)
	libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f031addb000)
	libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f031abd5000)
	libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f031a9d0000)
	libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f031a7ca000)
	libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f031a5af000)
	libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f031a394000)

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to pulseaudio in Ubuntu.

  pulseaudio not working

Status in pulseaudio package in Ubuntu:

Bug description:
  Binary package hint: pulseaudio

  I just upgraded from Jaunty to Karmic. I'm having issues with gnome-
  volume-control, it can't connect to sound system. After googling
  around I found menay report this doesn;t work without pulseaudio. I
  have got installed pulseaudio. I tried to reinstall it, remove it,
  also purge it and install it again. volume control still doesn't come
  up. Then I realize that what ever I do with pulseaudio in command line
  e.g. pulseaudio -vvvv or pulseaudio --version etc. basically anything
  I always get this error:

  pulseaudio: relocation error: pulseaudio: symbol pa_rtclock_now,
  version PULSE_0 not defined in file libpulse.so.0 with link time

  here is an output from last installation of the pulseaudio so you can
  see packages and versions

  Setting up libpulse-browse0 (1:0.9.19-0ubuntu4) ...

  Setting up pulseaudio-utils (1:0.9.19-0ubuntu4) ...
  Setting up pulseaudio-module-udev (1:0.9.19-0ubuntu4) ...
  Setting up pulseaudio (1:0.9.19-0ubuntu4) ...
  Adding user pulse to group audio
   * PulseAudio configured for per-user sessions

  Setting up pulseaudio-esound-compat (1:0.9.19-0ubuntu4) ...
  Setting up pulseaudio-module-x11 (1:0.9.19-0ubuntu4) ...
  Processing triggers for libc-bin ...
  ldconfig deferred processing now taking place

  I'd like to get volume-control and applet back working. I don't really
  mind pulseaudio not working because my sound seems to be working fine
  with inbuilt sound card and also with USB headphones. Just to mention
  I'm running on Sony  VAIO VGN series laptop.

  Thanks for your help.

To manage notifications about this bug go to: