← Back to team overview

desktop-packages team mailing list archive

[Bug 1523100] Re: Alsa not detecting internal microphone [ALC255]



1. There is no real benefit of 16.04, as it now has an older kernel
(4.3) than is available for wily (4.4). It once had better Intel HD
graphics support, but now the support has landed in 15.10. I'm now
running Ubuntu 15.10 too.

2. I've already tried node 0x19 for the internal microphone, but it
doesn't work (either I hear nothing or just plain white noise).

3. I'm not sure about the combined mic/headset jack. If they would have
integrated one in this PC, why would there then be a separate microphone

Raymond, I tested the internal mic using both sound recorder and cheese
and tried the stereo channels separately and together (using
pavucontrol) while going through the nodes in hdajackretask. You have a
point with the phasing, I might go through the nodes again just to make
sure, as I might have forgotten to try the channels separately on some
nodes :)

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to alsa-driver in Ubuntu.

  Alsa not detecting internal microphone [ALC255]

Status in alsa-driver package in Ubuntu:

Bug description:
  I've just installed Ubuntu 16.04 alongside Windows 10 on a 64bit Acer
  Aspire VN7-792G and noticed, that the internal microphone doesn't
  work. The computer has been released a couple of months ago and it's
  Intel Skylake -based with a Sunrise Point -based motherboard.

  INFO: The problem exists in Ubuntu 15.10 too, only microphone jack
  detected. Currently using Ubuntu 16.04 for proper hardware support.

  Alsa reports the audio device to be:

  Card: HDA Intel PCH
  Chip: Intel Skylake HDMI

  The speakers are working fine, but both alsamixer and pavucontrol
  (Pulseaudio Volume Control) raport the unplugged external microphone
  connector as the only sound input.

  I have tried many of the alsa model configurations (options snd-hda-
  intel model=something) without success, alsa finds only the microphone
  jack, which works fine when I plug an external microphone in it.

  Here's some info:

  lspci | grep -I audio:

  00:1f.3 Multimedia audio controller: Intel Corporation Sunrise Point-H
  HD Audio (rev 31)

  cat /proc/asound/cards:

  0 [PCH            ]: HDA-Intel - HDA Intel PCH
                              HDA Intel PCH at 0x84320000 irq 128

  And a clip from dmesg | grep snd:

  [    3.019164] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
  [    3.047505] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC255: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
  [    3.047508] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
  [    3.047510] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
  [    3.047511] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
  [    3.047512] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
  [    3.047512] snd_hda_codec_realtek hdaudioC0D0:    inputs:
  [    3.047514] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x1a

  One problem is that I can't find any model options (options snd-hda-
  intel model=something) or other parameters for the card's model
  (ALC255), I suppose this issue is relatively new.

  ApportVersion: 2.19.2-0ubuntu6
  Architecture: amd64
   /dev/snd/controlC0:  dennis     1180 F.... pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2015-11-11 (23 days ago)
  InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151110)
  Package: alsa-driver (not installed)
  ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
  Tags:  xenial
  Uname: Linux 4.2.0-19-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm bumblebee cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 09/25/2015
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: V1.02
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Aspire VN7-792G
  dmi.board.vendor: Acer
  dmi.board.version: V1.02
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V1.02
  dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.02:bd09/25/2015:svnAcer:pnAspireVN7-792G:pvrV1.02:rvnAcer:rnAspireVN7-792G:rvrV1.02:cvnAcer:ct10:cvrV1.02:
  dmi.product.name: Aspire VN7-792G
  dmi.product.version: V1.02
  dmi.sys.vendor: Acer

To manage notifications about this bug go to: