← Back to team overview

desktop-packages team mailing list archive

[Bug 1308105]


I still get this in xfce4-settings.4.12.0-3 when I shut off the monitor via its power button, or switch to another pc via a K-V-M switch. I'm unable to resume the display when switching back to my Linux pc or turning the power back on. I have to run 4.10.1-1. For a while I used the 4.11.3-3 fix from Manjaro but that doesn't work now either since last -Syu. I'm running Archlinux 4.3.0-1-ck on an Asus M5A88-M mobo, with on-board Radeon 4250 graphics using the HDMI port. The HDMI is directly connected to an Asus VS247 lcd monitor. The K-V-M only switches the keyboard and mouse from the Linux pc, the other pc's it also switches the VGA as they are connected to the monitor VGA (the monitor default is HDMI so I manually switch the monitor by its selector button to VGA for the VGA pc's). I have to remote into the Linux pc and do a normal reboot in order to get the display to turn on else use the power button on front of the Linux pc :(.
Not sure where to look to troubleshoot. Thank you for your consideration.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nvidia-graphics-drivers in Ubuntu.

  Xfce resets TV mode to NULL when power cycled

Status in Mythbuntu:
Status in xfce4-settings:
Status in nvidia-graphics-drivers package in Ubuntu:
Status in nvidia-graphics-drivers-331 package in Ubuntu:
Status in xfce4-settings package in Ubuntu:

Bug description:
  I had an HTPC with Mythbuntu 12.04 installed.  Upon upgrading a new
  behavior that if the TV is power cycled it no longer detects a link
  with the HTPC.

  When this happens I can find in the xorg log that there is an
  accompanying log item:

  [ 39829.509] (II) NVIDIA(0): Setting mode "NULL"

  After debugging with NVIDIA at
  detected/ we've deteremined it's a X client that reacts to the RANDR
  events causing the mode to be set to NULL.

  Working through the list in an Xfce environment, the culprit is
  xfsettingsd.  If xfsettingsd is running, it causes the TV to come up
  in a NULL mode.  If it's killed, it remains in the mode it was
  previously running in.

  Until this is fixed, this behavior can be worked around with a simple shell script:
  #Fix TV state when HDMI link is lost.
  #By Mario Limonciello <superm1@xxxxxxxxxx>


  for MODE in $BAD_MODE $GOOD_MODE; do
   DISPLAY=:0 xrandr --output $OUTPUT --mode $MODE
   sleep 2

To manage notifications about this bug go to: