← Back to team overview

desktop-packages team mailing list archive

[Bug 321287] Re: Seahorse won't generate a key when .gnupg directory owned by root, only gives unhelpful "General error"


Confirmed on Ubuntu 14.04 LTS.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to seahorse in Ubuntu.

  Seahorse won't generate a key when .gnupg directory owned by root,
  only gives unhelpful "General error"

Status in seahorse package in Ubuntu:

Bug description:
  Bug Summary (by nUboon2Age): When the ~/.gnupg/ directory and its
  contents are owned by root Seahorse gives: Couldn't generate PGP key
  // General error.  To get Seahorse working again the ~/.gnupg/
  directory must be deleted.  This allows Seahorse to run not only new
  gpg creation but also run 'Sync and Publish keys' which otherwise
  seems to stall indefinitely.  Bug fix suggestions in comments below.

  {original bug report below}
  Binary package hint: seahorse

  Seahorse will not generate a new key. I have used gksudo to launch
  seahorse from the command line. Seahorse opens. I press on the 'new'
  button to generate a new key. I select PGP key and press continue. I
  fill out the fields for 'real name', 'email address', and 'comment'. I
  click on the arrow for advanced options. I select 4096 for key
  strength. I remove the check from the box that says never expires. I
  click on 'Create'. It asks me for a Passphrase for New PGP Key. I
  enter my password two times, the same both times.  I click oK.

  A box pops up with an error message in it:

  <big><b>Couldn't generate PGP key</b></big>

  General error

  The html tags are in the actual error message. No key is generated.

  I am running Ubuntu 8.10
  gpg is installed:
  em@leibniz:~$ gpg --version
  gpg (GnuPG) 1.4.9
  em@leibniz:~$ uname -a
  Linux leibniz 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux


  I  too have the similar problem:
  right click on folder, select "Encrypt".  At this point I get message that no key are available and seahorse opens up.

  I click on File, New, fill out name, email, comment, leave other
  defaults alone.  Next I get the password box I fill in the password,
  and the working bar apears for about a minute or two and then I get an
  error message saying that it can not generate key.

  I was running 8.10 with latest patches, last night I upgraded to 9.04
  to see if it would help, but it did not, still get the same error.

  Thanks for any one looking into this.

To manage notifications about this bug go to: