← Back to team overview

desktop-packages team mailing list archive

[Bug 1537680] Re: Missing calendar items from CalDAV ressource


** Attachment added: "Missing event details"

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to akonadi in Ubuntu.

  Missing calendar items from CalDAV ressource

Status in akonadi package in Ubuntu:

Bug description:
  I'm using DavMail [1] as a middleware between Akonadi and my company's
  Microsoft Exchange server. In order to get my calendar shown in
  Kontact, I have set up a CalDAV resource, pointing to DavMail's local
  URL. Most of my VEvents show up fine, except for some events (both
  repeating and non-repeating events).

  When I download the calendar manually (by opening the calendar URL in
  a browser) and then add it as iCal ressource, all events are shown,
  including those who are missing in the CalDAV ressource.

  I tried to find out how to debug this, to see if something is going
  wrong during import, but I do not know how to do this properly:

  - I ran "akonadictl restart" from the command line, to get some debugging output
  - I ran "gdb akonadi_control" and added the CalDAV ressource
  - I followed the "Debugging Akonadi Agents" tutorial [2]

  Maybe I'm looking at the wrong place?

  [1] http://davmail.sourceforge.net/
  [2] https://techbase.kde.org/Projects/PIM/Akonadi/Development_Tools#Attaching_gdb_at_startup

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: akonadi-server 1.13.0-2ubuntu4
  ProcVersionSignature: Ubuntu 3.19.0-47.53-generic 3.19.8-ckt10
  Uname: Linux 3.19.0-47-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.8
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Mon Jan 25 10:10:55 2016
  InstallationDate: Installed on 2015-10-13 (104 days ago)
  InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  JournalErrors: Error: command ['journalctl', '-b', '--priority', 'warning'] failed with exit code 1: No journal files were found.
  SourcePackage: akonadi
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: