← Back to team overview

desktop-packages team mailing list archive

[Bug 1318360] Re: Poor microphone quality (mako)


I had the same problem, also tried to flash the new firmware, but it didn't affect the quality. 

So I have adjusted alsamixer and it worked for me. Actually, I have done
it try-and-error and I don't know much about the details, but maybe this
helps someone, so I'll show you what I have done:

- start terminal
- start alsamixer by tiping "alsamixer" in the terminal 
- chose  "Capture" by clicking F4
- click the right arrow key (roughly twomillion times^^) until I arrive to "RX1 Digital"
- the RX1 until 7 Digitals are the gains that I changed, because they affect the quality. What I have done is, that I  reduced the gain for RX2 until RX7, all down to around 55 (reducing is simply done by pressing the "down arrow"). The gain for RX1 must not be adjusted that low, because it somehow it affects the incoming call volume, and when I reduced this value, it was hard for me to understand the people. 
- That did the trick for me, I haven't done some very specific fine tuning, maybe I will do it later and tell you the results :). But since this solution works very well for me, maybe I'll leave it that way...

I hope this will be helpful for someone; if anyone has any feedback or
improvements, please share!

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to pulseaudio in Ubuntu.

  Poor microphone quality (mako)

Status in pulseaudio package in Ubuntu:

Bug description:
  After months of complaints from people talking to me on the phone
  (mako ubuntu touch), I finally got around to use multiROM to dual boot
  Ubuntu Touch and Android. Several people can confirm that there is a
  noticable difference in terms of sound/microphone quality between
  Android and UT in phone calls. With UT, my voice gets distorted to an
  extent that person at the other end have real difficulties to hear
  what I am saying, while with Android call quality is much better with
  no distortion.

  I have had a suspicion for a long time that this might be a software
  and not a hardware issue. After trying Android and Ubuntu on the same
  hardware I believe this suspicion is proved correct. This issue has
  persisted in all the builds I have tried since at least the beginning
  of the year, but probably longer. I am now at r17 of Utopic.

To manage notifications about this bug go to: