← Back to team overview

desktop-packages team mailing list archive

[Bug 1539284] Re: Firefox 44.0 repeatedly crashes on ARMHF


Since the bug's still open, I did have it reoccur but found the cause
and fixed it.  I had switched to the mesa libGL.so.1 to build some
software*, and firefox 44.0 runs with this, but did crash when I went
back to tegra libGL.  Long story short, the firefox profile's from my
previous portable and had gfx.blacklist.*, webgl.force-neabled and
layers.acceleration.force-enabled settings in there, clearing these
fixed it.  I cleared layers.acceleration.force-enabled last, this was
causing it in particular.

about:support indicates hardware accel is off (firefox disables on
nvidia driver less than 257.21, and tegra driver shows as nvidia version
21.4).  I looked to see if there was any bug report of recent layers-
related crashes (new between 43 and 44), but I didn't find anything;
presumably it works on supported drivers.

* The tegra libGL.so.1 causes dpkg-buildpackage to fail to build any
package that uses OpenGL, with an error that there is no dependency info
for libGL.so.1, but with mesa libGL.so.1 it builds fine and runs with
either libGL.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to firefox in Ubuntu.

  Firefox 44.0 repeatedly crashes on ARMHF

Status in firefox package in Ubuntu:

Bug description:
  (First off, I did try to use ubuntu-bug, as well as collecting info
  with apport-cli then submitting with ubuntu-bug.  The several
  automated bug reports I filed just hung up, launchpad claimed it was
  processing the report and refreshed for over an hour.)

  Running firefox_43.0.4+build3-0ubuntu0.14.04.1_armhf is running fine.
  44.0+build3-0ubuntu0.14.04.1 repeatedly crashes.

   I tried removing all my extensions (first in Firefox 44, but it
  crashed loading the about:addons), then manually (moving them out of
  extensions directory).  No help.  I restored my profile from a backup,
  went to Ubuntu 43.0.4 and uninstalled the extensions there.    Upon
  upgrade to Ubuntu 44.0, it crashes repeatedly with no extensions.  One
  crash did indicate a floating point exception, the rest just inidcated
  "signal 11".

  I'm running Ubuntu 14.04.4 for ARMHF on a Acer Chromebook 13.  This
  has a Tegra K1, a quad-core ARM with an Nvidia video card with
  192-core CUDA unit (the GK20A is closest in specs to a Geforce GT720
  or so.)

  Let me know if you want more information.  Thanks!

To manage notifications about this bug go to: