← Back to team overview

desktop-packages team mailing list archive

[Bug 1462183] Re: Nautilus "Enter Location" Stops Working


This problem usually arises when you have two Nautilus windows open, and
one is already in "location" mode, i.e. the address bar shows the text
of the path, call it window #2. If you minimize this window #2, activate
window #1, and hit "Ctrl+L", nothing happens. The worst part is that
even if you close the window #2, where you had it working, it will still
not work for window #1. If you then open window #3 and minimize it, hit
"Ctrl+L" in window #1, it will be applied to window #3 (!).

It is obviously a usability bug that has to do with incorrect code
design for handling "Ctrl+L" in multiple windows.

This problem affects all versions of Ubuntu using nautilus up to and
including 15.10, and will probably continue to affect 16.04 until
something is done about it.

@Vindicator, if what I described above is not what you are experiencing,
please let me know and I'll try to file a separate bug report.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nautilus in Ubuntu.

  Nautilus "Enter Location" Stops Working

Status in nautilus package in Ubuntu:

Bug description:
  Earlier, I had been able to use CTRL-L for "Enter Location" and it
  worked. At some point I had pressed ESC to revert back to the button-
  based paths.

  Later on, with that same window open, I came back and tried CTRL-L and the path didn't switch back to the textbox.
  Even going to "Go"->"Enter Location" did nothing.

  While writing this up, I did a test by closing that window, then opening a new "Files" window and CTRL-L worked right off the bat.
  This wasn't my first experience with that "bug", but enough times for me to finally submit it when it happened.

  Hopefully the data submitted will provide the information needed to
  find the cause.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: nautilus 1:3.14.2-0ubuntu9
  ProcVersionSignature: Ubuntu 3.19.0-20.20+test-generic 3.19.8
  Uname: Linux 3.19.0-20-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Jun  4 23:41:00 2015
  EcryptfsInUse: Yes
  ExecutablePath: /usr/bin/nautilus
   b'org.gnome.nautilus.list-view' b'default-visible-columns' b"['name', 'size', 'date_modified', 'mime_type']"
   b'org.gnome.nautilus.list-view' b'use-tree-view' b'true'
   b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'owner', 'group', 'permissions', 'mime_type', 'where']"
  InstallationDate: Installed on 2015-06-04 (1 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
   PATH=(custom, no user)
  SourcePackage: nautilus
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: