← Back to team overview

desktop-packages team mailing list archive

[Bug 1293525] Re: add apparmor profile for transmission-gtk


I tried this under Ubuntu GNOME 14.04.

- Transmission crashes when opening the Preferences dialog. Adding "/usr/** r" solved this. I think this can be made more specific as in usr.lib.telepathy.
- This profiles is probably too restrictive when trying to select a download location other than @{HOME}/Downloads. The file selector dialog gives access denied error, so you can only type the correct path manually.
- Help (F1) does not seem to work (needs /usr/bin/xdg-open?).
- Donate does not form (needs firefox.sh?).
- I needed to remove #include <abstraction/lightdm> (I guess this is Ubuntu GNOME specific).
- I added abstaction/dbus, abstraction/dbus-session and abstraction/ibus to silence some complaints.
- I added some dconf related rules from usr.lib.telepathy to silence some complaints.
- I added read access to /etc/mtab, /etc/fstab to silence some complaints.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to transmission in Ubuntu.

  add apparmor profile for transmission-gtk

Status in “apparmor” package in Ubuntu:
Status in “transmission” package in Ubuntu:

Bug description:
  There should be an apparmor profile for transmission-gtk.  Attached is
  a draft for discussion.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: apparmor-profiles 2.8.0-0ubuntu38
  ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
  Uname: Linux 3.13.0-17-generic x86_64
  ApportVersion: 2.13.3-0ubuntu1
  Architecture: amd64
  CurrentDesktop: LXDE
  Date: Mon Mar 17 13:36:19 2014
  InstallationDate: Installed on 2014-03-07 (9 days ago)
  InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha amd64+mac (20140307)
  PackageArchitecture: all
  ProcKernelCmdline: BOOT_IMAGE=/boot/vmlinuz-3.13.0-17-generic root=UUID=b44a2e83-f3f2-4e70-800d-04964b932c90 ro quiet splash
  SourcePackage: apparmor
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: