← Back to team overview

desktop-packages team mailing list archive

[Bug 1296387] Re: CUPS takes very long time to print PDF or raw PS file.


[Expired for cups (Ubuntu) because there has been no activity for 60

** Changed in: cups (Ubuntu)
       Status: Incomplete => Expired

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to cups in Ubuntu.

  CUPS takes very long time to print PDF or raw PS file.

Status in “cups” package in Ubuntu:

Bug description:
  > uname -a
  Linux magrathea 3.2.0-57-generic #87-Ubuntu SMP Tue Nov 12 21:35:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

  > cat /etc/os-release
  VERSION="12.04.3 LTS, Precise Pangolin"
  PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"

  > Using cups version 1.5.3

  I have a Brother HL-4070CDW, which is a color duplex laser printer.
  I've attached it with USB. The printer has 320MB of memory, so the
  problem seems to lie somewhere in the spooling or pre-processing. I am
  printing directly with lp and lpr.

  Printing certain files takes far too long. For example, I have a 35MB
  PDF file, 9 pages of text with some large-ish JPEGs. The printer will
  print a page, one sided or two sided, and then stop. Constantly
  refreshing the CUPS page at localhost:631 reveals that only a couple
  of pages come through at a time. Htop reveals that pdftops -level2
  -origpages -r 300 /tmp/somefile is running all the while sending some
  trickle of data to the printer. Thinking there was some problem here,
  I ran pdftops on the file itself, and instantly got a 45MB ps file,
  again, the printer has over 300MB of memory, so the problem doesn't
  lie there. When I tried to print this ps file with lpr -l (i.e., raw
  file mode), there was no speedup. Also, IIRC pdftops is still being
  run when I invoke lpr -l on the ps file, which seems totally wrong.

  I enabled debug level logging in CUPS and see that the data is being
  sent 8 kilobytes at a time to the printer. Considering this is USB
  2.0, I don't understand why the whole file isn't transferring almost
  immediately, because, as I reiterated, the printer has more than
  enough available memory. This print job should spool immediately and
  allow my printer to run at its maximum output speed, but again, there
  are gaps between each page or 2 page spurt of up to a few minutes.

  I have attached the CUPS log in case that may be of use.

  Please let me know if there are any details I omitted or any
  information or command outputs you need to diagnose this problem and
  recommend a solution.

  Any help you folks can render will be greatly appreciated!

  Thanks in advance,

To manage notifications about this bug go to: