← Back to team overview

desktop-packages team mailing list archive

[Bug 1184725] Re: Laserjet 3150 doesn't print


I haven't been able to test this on 14.04. I use 14.04 now and I believe
the parallel port was disabled in HP driver long ago. If the parallel
port is still disabled then I would recommend filing this bug as an hp

Anyway I can't generate a cups report because it doesn't use cups(only
hplip is supported). I thought it was very strange that a parallel port
printer would no longer work because the driver doesn't support parallel
ports. Ideally we, as a community, could just add some kind of cups
driver for this printer an bypass HP altogether. In hteory, everything
is there and works, plus it has worked flawlessly until HP droppedthe
parallel port.

** Changed in: cups (Ubuntu)
       Status: Expired => In Progress

** Package changed: cups (Ubuntu) => hplip (Ubuntu)

** Changed in: hplip (Ubuntu)
       Status: In Progress => Confirmed

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to cups in Ubuntu.

  Laserjet 3150 doesn't print

Status in “hplip” package in Ubuntu:

Bug description:
  HP Laserjet 3150 connected to parallel port doesn't print test page (or anything). The printer is detected and installs fine. It says it printed fine but nothing happens and no errors. Initially I got Device communication error 5012 hplip... but now the error is gone after installing the latest hplip and enabling EPP in bios. Prints fine on winXP. Tried using the repository drivers, followed by compiling the latest from HP. Also tried the hpijs driver. Tried rebooting. Tried adding via system printer dialogue and hp-setup. Network printing to another printer works fine(HP Officejet L7555). Verified the bios is using EPP mode. Verified the kernel sees the /dev/parport0. Verified the following:
  lsmod | grep lp 
  lp                     17759  0 
  parport                46345  3 lp,ppdev,parport_pc

  dmesg | grep par
  [   21.005872] parport_pc 00:06: reported by Plug and Play ACPI
  [   21.005908] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
  [   21.057906] parport0: Printer, Hewlett-Packard HP LaserJet 3150
  [   21.255534] ppdev: user-space parallel port driver
  [   21.256223] lp0: using parport0 (interrupt-driven).

  ls -l /dev/lp* /dev/parport*
  crw-rw---- 1 root lp  6, 0 May 27 00:14 /dev/lp0
  crw-rw---- 1 root lp 99, 0 May 27 00:14 /dev/parport0

  ls -l /proc/sys/dev/parport/parport*/autoprobe*
  -r--r--r-- 1 root root 0 May 27 11:56 /proc/sys/dev/parport/parport0/autoprobe
  -r--r--r-- 1 root root 0 May 27 11:56 /proc/sys/dev/parport/parport0/autoprobe0
  -r--r--r-- 1 root root 0 May 27 11:56 /proc/sys/dev/parport/parport0/autoprobe1
  -r--r--r-- 1 root root 0 May 27 11:56 /proc/sys/dev/parport/parport0/autoprobe2
  -r--r--r-- 1 root root 0 May 27 11:56 /proc/sys/dev/parport/parport0/autoprobe3

  sudo cat /proc/sys/dev/parport/parport*/autoprobe* 
  MODEL:HP LaserJet 3150;
  DESCRIPTION:Hewlett-Packard LaserJet 3150 MFP;

  lpinfo -v
  network socket
  network lpd
  network ipp
  network https
  network http
  network ipps
  network ipp14
  direct parallel:/dev/lp0
  network beh
  network smb
  network dnssd://Officejet%20Pro%20L7500%20%5B067B1C%5D._pdl-datastream._tcp.local/

  direct parallel:/dev/lp0 "HP LaserJet 3150" "HP LaserJet 3150 LPT #1" "MANUFACTURER:Hewlett-Packard;COMMAND SET:HP GDI,ECP18;1284.4DL:0;MODEL:HP LaserJet 3150;CLASS:PRINTER;DESCRIPTION:Hewlett-Packard LaserJet 3150 MFP;" ""

  sudo /usr/lib/cups/backend/parallel
  direct parallel:/dev/lp0 "HP LaserJet 3150" "HP LaserJet 3150 LPT #1" "MANUFACTURER:Hewlett-Packard;COMMAND SET:HP GDI,ECP18;1284.4DL:0;MODEL:HP LaserJet 3150;CLASS:PRINTER;DESCRIPTION:Hewlett-Packard LaserJet 3150 MFP;" ""

  ls -al /dev/parport0
  crw-rw---- 1 root lp 99, 0 May 27 00:14 /dev/parport0

  stinky adm lp cdrom sudo dip plugdev lpadmin sambashare

  I read another post about the wrong command set for this printer but I
  don't know where to change it or what to change it to?

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: cups 1.6.2-1ubuntu5
  ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
  Uname: Linux 3.8.0-22-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.9.2-0ubuntu8
  Architecture: amd64
  Date: Mon May 27 11:37:35 2013
  InstallationDate: Installed on 2012-08-21 (279 days ago)
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
   device for Hewlett-Packard-HP-LaserJet-3150: parallel:/dev/lp0
   device for Officejet-Pro-L7500: dnssd://Officejet%20Pro%20L7500%20%5B067B1C%5D._pdl-datastream._tcp.local/
   device for Officejet_Pro_L7500: hp:/net/Officejet_Pro_L7500?zc=HP067B1C
   device for Officejet_Pro_L7500_fax: hpfax:/net/Officejet_Pro_L7500?zc=HP067B1C
  MachineType: Gateway GT5028
  MarkForUpload: True
  Papersize: letter
   Officejet_Pro_L7500: HP Officejet Pro l7500, hpcups 3.13.3
   Hewlett-Packard-HP-LaserJet-3150: HP LaserJet 3150 hpijs, 3.13.3
   Officejet_Pro_L7500_fax: HP Fax hpcups
   Officejet-Pro-L7500: HP Officejet Pro l7500, hpcups 3.13.3
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-22-generic root=UUID=08c0de72-7d32-46e7-8764-d2a3e32f0817 ro quiet splash
  SourcePackage: cups
  UpgradeStatus: Upgraded to raring on 2013-05-22 (5 days ago)
  dmi.bios.date: 02/10/2006
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: 6.00 PG
  dmi.board.name: C51MCP51
  dmi.chassis.type: 3
  dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd02/10/2006:svnGateway:pnGT5028:pvr:rvn:rnC51MCP51:rvr:cvn:ct3:cvr:
  dmi.product.name: GT5028
  dmi.sys.vendor: Gateway

To manage notifications about this bug go to: