← Back to team overview

desktop-packages team mailing list archive

[Bug 1365695] Re: No longer able to use GUI after update


OK, I upgraded to ubuntu-drivers-common to reproduce the
original problem and then installed xserver-xorg-video-intel
2:2.99.910-0ubuntu1.2~ppa1, which resolves the issue.

Great, thanks!

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nvidia-graphics-drivers-331-updates in

  No longer able to use GUI after update

Status in “nvidia-graphics-drivers-304-updates” package in Ubuntu:
Status in “nvidia-graphics-drivers-331” package in Ubuntu:
Status in “nvidia-graphics-drivers-331-updates” package in Ubuntu:
Status in “ubuntu-drivers-common” package in Ubuntu:
  Fix Released
Status in “xserver-xorg-video-intel” package in Ubuntu:
Status in “nvidia-graphics-drivers-304-updates” source package in Trusty:
Status in “nvidia-graphics-drivers-331” source package in Trusty:
Status in “nvidia-graphics-drivers-331-updates” source package in Trusty:
Status in “ubuntu-drivers-common” source package in Trusty:
Status in “xserver-xorg-video-intel” source package in Trusty:

Bug description:
  Until yesterday the 14.04 install on this Thinkpad T530 (nvidia
  Optimus) with nvidia-331 drivers worked just fine, including excellent
  multi-monitor behavior. Yesterday the set of packages below [1] was
  updated. I shut down, booted this morning and found out that I was not
  shown the lightdm login screen: I was stuck at the purple screen that
  precedes it (into which I enter my disk encryption password).

  Now the funny thing is that I could hear the lightdm startup sound and
  could actually login by typing my password (disk activity and started
  processes verify I am actually logged in), but I can't see anything:
  I'm still stuck at the puple screen.

  Uninstalling the nvidia drivers solved the problem: I'm typing this in
  a browser window using the nouveau drivers.

  I atttempted switching to nvidia-304, but that doesn't work either.
  Using those drivers I am shown the lightdm login screen, but after
  logging in I'm stuck with a screen showing only the background image.
  Nothing else is available, no keyboard or mouse trickery will reveal
  any menu, dialog or terminal to gain access.

  Since nouveau doesn't support a multi-monitor setup, it would be great
  if I someone could tell me how to get the nvidia drivers working

  Some things I noticed:
  - .xsession-errors reported 'Xlib:  extension "GLX" missing on display ":0"'
  - /var/log/Xorg.0.log reported 'setversion 1.4 failed: Permission denied'

  [1] The packages that were updated:

  Start-Date: 2014-09-03  15:07:38
  Upgrade: libsystemd-login0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), systemd-services:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), librbd1:amd64 (0.80.1-0ubuntu1.1, 0.80.5-0ubuntu0.14.04.1), ubuntu-drivers-common:amd64 (,, libsystemd-daemon0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libgudev-1.0-0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libgudev-1.0-0:i386 (204-5ubuntu20.4, 204-5ubuntu20.5), libpam-systemd:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), librados2:amd64 (0.80.1-0ubuntu1.1, 0.80.5-0ubuntu0.14.04.1), shotwell-common:amd64 (0.18.0-0ubuntu4.1, 0.18.0-0ubuntu4.2), udev:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), shotwell:amd64 (0.18.0-0ubuntu4.1, 0.18.0-0ubuntu4.2), gir1.2-gudev-1.0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libudev-dev:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libudev1:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), libudev1:i386 (204-5ubuntu20.4, 204-5ubuntu20.5), xserver-xorg-video-intel:amd64 (2.99.910-0ubuntu1, 2.99.910-0ubuntu1.1), libsystemd-journal0:amd64 (204-5ubuntu20.4, 204-5ubuntu20.5), rsyslog:amd64 (7.4.4-1ubuntu2, 7.4.4-1ubuntu2.1)
  End-Date: 2014-09-03  15:08:06

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: nvidia-current-updates (not installed)
  ProcVersionSignature: Ubuntu 3.13.0-35.62-generic
  Uname: Linux 3.13.0-35-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.14.1-0ubuntu3.3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Sep  4 22:07:11 2014
  SourcePackage: nvidia-graphics-drivers-304-updates
  UpgradeStatus: Upgraded to trusty on 2014-06-03 (93 days ago)

To manage notifications about this bug go to: