← Back to team overview

desktop-packages team mailing list archive

[Bug 1382462] Re: Desktop/windows painted incorrectly in dual monitor configuration


Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xorg (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Desktop/windows painted incorrectly in dual monitor configuration

Status in “xorg” package in Ubuntu:

Bug description:
  My setup: Dell M4600 laptop with Dell U3011 2560x1600 monitor attached
  to DisplayPort.

  I was using Nvidia 331.38 prioprietary driver for quite a long time
  with Ubuntu 14.04 LTS and everything worked perfectly. Today I
  upgraded to Ubuntu 14.10, which comes with Nvidia 331.89 and observed
  the following problem:

  1. When I boot up the computer with the monitor connected, the login
  screen looks fine. Both displays get detected properly and resolutions
  are ok (1920x1080 on the builtin laptop display and 2560x1600 on
  U3011) and screen contents scaled properly.

  2. Then I log into my account, for 3 seconds U3011 displays some
  rubbish (but it was always like that) and when it finally logs in, it
  displays everything stretched horizontally through both my screens. It
  looks as if it tried to paint the contents of a single display on two
  of them, by stretching the content horizontally, so everything (icons,
  windows, wallpaper) has wrong aspect-ratio. Funny, the top status bar
  seem to render correctly and the resolution/size of the top menu is
  correct. Physical resolution of both screens is ok. I'll attach a
  photo, because it is hard to describe how it looks.

  3. I cannot use system in this state - mouse click position seems to
  not be synchronized with what's on the display - e.g. I can start
  applications, but then they don't react to mouseclicks.

  However: booting up without the second display connected, logging in
  and *then* connecting the second display works fine.

  If I boot up with connected monitor and log in (desktop distorted), disconnecting and connecting monitor does *not* help. After disconnecting the U3011, the builtin display is painted ok, but after connecting, it returns back to the incorrect state and both are rendered incorrectly.
  The only thing that helps recovering from this state seems to be disconnecting the second monitor, reboot, logging in and then connecting.

  Suspending to memory and waking up does not change the layout of the
  screen (neither fixes the "broken" one nor destroys the "good" one).

  Using a Guest session instead of my account does not fix my problem (I
  was hoping this was something screwed up in my .config).

  Switching to a Guest user account while I'm using both monitors in the
  good layout creates a session with a broken layout. Then logging out
  from Guest and switching back to my original session restores the good
  layout. The good layout seems to not be forgotten until I finish the
  session and logout. The bad layout is "created" whenever I start a new
  session with both monitors plugged in.

  BTW: I'm using a docking station - not sure if it is related - if you
  think it might be, I can try with connecting the monitor directly.

  I tried deleting ~/.compiz and ~/.config/compiz-1 directories but the problem remains.
  I also tried to go into the Displays configuration when everything is ok, apply the settings there (without any changes) in hope it will persist them somehow, but after restart it is broken again.

  I also tried reinstalling nvidia 331.89 drivers, because it complained
  about not being able to install nvidia-uvm during the upgrade process
  (reported separately), and now all nvidia packages installed cleanly.
  Before that I also got rid of all the ppa mainline kernels I had, just
  in case they mess something up.

  I remember the same problem happened on Ubuntu 14.04 when I tried to
  upgrade nvidia from ppa/xorg-edgers to 331.89, but then the easy
  workaround was to downgrade back to official 331.38. Now I have no
  choice :(

  Some other observations that may or may not be related to the problem,
  but I disclose them anyway, maybe they are helpful:

  * Notifications (e.g. network connection) displayed on the login
  screen in dual screen mode seem to be misplaced and instead of being
  painted in the upper right corner of one of the displays they get
  painted in some hard to logically explain position - neither at the
  center, nor in any corner.

  * The splash screen of IntelliJ IDEA (this is using Java / AWT
  probably) is also rendered in a strange position - below the center of
  the laptop screen, moved to the right (but not touching the edge),
  instead of exact center as it should be.

  * GMail notification just displayed at the moment when I'm writing it
  exactly at the left-lower corner of the bigger screen (U3011).

  * Nvidia settings lists only U3011 in the list of the devices
  (attached screenshot).

  * Ubuntu Display configuration dialog detects both displays correctly
  and their positions and resolutions are ok (attached screenshot).
  However I could not check that when the problem was active.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: xorg 1:7.7+7ubuntu2
  ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
  Uname: Linux 3.16.0-22-generic x86_64
  NonfreeKernelModules: nvidia
  .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
  .proc.driver.nvidia.registry: Binary: ""
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  331.89  Tue Jul  1 13:30:18 PDT 2014
   GCC version:  gcc version 4.9.1 (Ubuntu 4.9.1-16ubuntu6)

  ApportVersion: 2.14.7-0ubuntu7
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
  Date: Fri Oct 17 11:02:50 2014
  DistUpgraded: 2014-10-17 10:20:38,145 DEBUG enabling apt cron job
  DistroCodename: utopic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, including running git bisection searches
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:04a3]
   NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:14a3]
  InstallationDate: Installed on 2012-03-21 (939 days ago)
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  MachineType: Dell Inc. Precision M4600
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-22-generic root=UUID=37dce0bb-1e68-402b-8cba-78a6e04193de ro quiet splash reboot=pci acpi_backlight=vendor resume=UUID=4b9dc764-1ab9-4d9f-b661-1561bfe83648
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to utopic on 2014-10-17 (0 days ago)
  dmi.bios.date: 10/18/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 08V9YG
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA08:bd10/18/2011:svnDellInc.:pnPrecisionM4600:pvr01:rvnDellInc.:rn08V9YG:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: Precision M4600
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
  version.ia32-libs: ia32-libs 20090808ubuntu36
  version.libdrm2: libdrm2 2.4.56+git20140920.77dce9a0-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.4.0~git20140925.23247e80-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.4.0~git20140925.23247e80-0ubuntu0ricotz~trusty
  version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to: