← Back to team overview

desktop-packages team mailing list archive

[Bug 1382055] Re: Trusty/HybridGraphics: nvidia not detected, prime-switch segfaulting since introduced.


I found a working combination:
nvidia-331 nvidia-settings-updates     from xorg-edgers
ubuntu-drivers-common:1:      from packages.ubuntu.com (utopic!)


dpkg -l | grep nvidia:

ii  nvidia-331                                            331.89-0ubuntu1~xedgers14.04.2                         amd64        NVIDIA binary driver - version 331.89
ii  nvidia-libopencl1-331                                 331.89-0ubuntu1~xedgers14.04.2                         amd64        NVIDIA OpenCL Driver and ICD Loader library
ii  nvidia-opencl-icd-331                                 331.89-0ubuntu1~xedgers14.04.2                         amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                          0.6.2                                                  amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                       343.13-0ubuntu1~xedgers14.04.1                         amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                               343.13-0ubuntu1~xedgers14.04.1                         amd64        Transitional package for nvidia-settings

** Changed in: xorg (Ubuntu)
       Status: New => Fix Committed

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Trusty/HybridGraphics: nvidia not detected, prime-switch segfaulting
  since introduced.

Status in “xorg” package in Ubuntu:
  Fix Committed

Bug description:
  I had a working system a month ago,  with a lucky xorg.conf that allowed the unity desktop to use gdm as window manager, and the mini-displayport to work (wired to the nvidia card).
  I hadn't updated for a month (mid-August 2014), because it was a production system, and then on 28 Sep 2014, after a full update and restart, gdm only worked on the built-in screen again, only with the intel card. Nvidia-settings suddenly is much smaller, and has a switch option, that does not work (gives an empty warning box as response, if I try to switch to nvidia from intel).

  - The result of prime-switch nvidia is "Segmentation fault",
  - The gpu manager log says "Has nvidia? no",
  - Xorg.0.log says "Failed to load module "nvidia" (module does not exist, 0)"

  - sudo modprobe nvidia finishes without error, only, because I added
  the line "alias nvidia nvidia-331" to /etc/modprobe.d/nvidia-

  - The command: sudo prime-select nvidia results in:
  Error: alternatives are not set up properly
  Error: nvidia mode can't be enabled

  - lspci output:
  00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
  01:00.0 VGA compatible controller: NVIDIA Corporation GK106M [GeForce GTX 770M] (rev a1) (prog-if 00 [VGA controller])

  - the xorg.conf is constantly deleted, which is annoying, I had a nice working version earlier
  - the best kernel option, that used to work was nvidia.modeset=1, I tried nomodeset and nothing, but none of them help

  I'd appreciate some help here, even if it's a revert (when was
  gpumanager introduced?), I just need to continue work as quickly as


  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8
  ProcVersionSignature: Ubuntu 3.13.0-37.64-generic
  Uname: Linux 3.13.0-37-generic x86_64
  NonfreeKernelModules: nvidia wl
  .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
  .proc.driver.nvidia.registry: Binary: ""
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  331.38  Wed Jan  8 19:32:30 PST 2014
   GCC version:  gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)

  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Thu Oct 16 14:06:17 2014
  DistUpgraded: 2014-06-06 12:58:55,700 DEBUG enabling apt cron job
  DistroCodename: trusty
  DistroVariant: ubuntu
   bbswitch, 0.7, 3.13.0-37-generic, x86_64: installed
   bcmwl,, 3.13.0-35-generic, x86_64: installed
   bcmwl,, 3.13.0-37-generic, x86_64: installed
   bcmwl,, 3.13.0-38-generic, x86_64: installed
   nvidia-331, 331.38, 3.13.0-37-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
   Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:05aa]
   NVIDIA Corporation GK106M [GeForce GTX 770M] [10de:11e0] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:05aa]
  MachineType: Alienware Alienware 17
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic root=UUID=2c5dc3f6-ea71-4ae6-b6d9-adc1534ff0bb ro nomodeset nosplash
  Renderer: Software
  SourcePackage: xorg
  UpgradeStatus: Upgraded to trusty on 2014-06-06 (132 days ago)
  dmi.bios.date: 07/15/2013
  dmi.bios.vendor: Alienware
  dmi.bios.version: A03
  dmi.board.name: 068R5X
  dmi.board.vendor: Alienware
  dmi.board.version: A01
  dmi.chassis.type: 8
  dmi.chassis.vendor: Alienware
  dmi.chassis.version: A03
  dmi.modalias: dmi:bvnAlienware:bvrA03:bd07/15/2013:svnAlienware:pnAlienware17:pvr1747:rvnAlienware:rn068R5X:rvrA01:cvnAlienware:ct8:cvrA03:
  dmi.product.name: Alienware 17
  dmi.product.version: 1747
  dmi.sys.vendor: Alienware
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.58+git20141006.00847fa4-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.4.0~git20141006.ca824e69-0ubuntu0ricotz~trusty
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.4.0~git20141006.ca824e69-0ubuntu0ricotz~trusty
  version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.99+git20140806.fbf575cb-0ubuntu0sarvatt~trusty
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.916+git20141006.ec2b9ac8-0ubuntu0sarvatt~trusty
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
  xserver.bootTime: Thu Oct 16 13:59:49 2014
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log

  xserver.version: 2:1.15.1-0ubuntu2.1

To manage notifications about this bug go to: