← Back to team overview

desktop-packages team mailing list archive

[Bug 1086564] Re: Problems printing from Xubuntu are same old story (Kyocera FS-1010) - perhaps an O/S memory-handling issue?


duplicate of https://bugs.launchpad.net/ubuntu/+source/foomatic-
db/+bug/1306849 ?

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to foomatic-db in Ubuntu.

  Problems printing from Xubuntu are same old story (Kyocera FS-1010) -
  perhaps an O/S memory-handling issue?

Status in “foomatic-db” package in Ubuntu:

Bug description:
  Xubuntu 12.10 - just installed
  Kyocera FS-1010 printer
  4Gb RAM

  Printer stopped working after install.

  It worked immediately following the install, for a few days. It
  printed a test page and at least one pdf successfully. Since then it
  has stopped working.

  Problem occurred trying to print a pdf with Okular. That seemed to jam
  everything up - not paper jam - but data jam. Then it wouldn't even
  print a test page, even after clearing the print queue.

  If you clear the print queue, reset the printer and then try and print
  a text file from e.g. Gedit, that's fine. But if you then try and
  print a pdf, it jams the queue and won't even print with Gedit.

  If you then clear the queue and reset the printer, Gedit prints fine.
  Then print with Docoment Viewer and it sits there for a few minutes
  and prints half a page and *jams the printer* - this time a paper jam.
  That's further than it got before.

  Leave the pdf in the print queue this time and reset the printer: now what is left in the print queue of the pdf that jammed before prints successfully. Then...
  Gedit: prints fine.
  Then Document Viewer: fine. Oh it appears to be working again now.
  Then Okular: printed just 7 of 41 pages from another pdf. And the printer has data-jammed again.

  There are 3 pdfs open at this point, so: close all the pdfs, clear the print queue again. Reset the printer. Now...
  Gedit: fine.
  Okular - 3-page document: fine.
  Okular - same 41-page pdf again: stuck at page 7 again.

  Clear queue, reset printer.
  Gedit - 19-page document: fine.
  Document Viewer - same 41-page pdf that failed with Okular: data-jam (waited 10 mins).

  So, reset printer without clearing queue: document prints after about 1min30.
  Gedit - 8-page document: prints 7 pages then stops. Oops thought this one was all 8 pages done. So went to next test.
  Document Viewer - same 41-page pdf: prints p8 of the last gedit run. Then prints an error report on the printer:


  And printer error lights flashing. Oops. Opened lid to see if paper
  jam before making a note of which lights were flashing. There was no
  paper jam. After closing lid, the lights were flashing an error code
  that the Kyocera FS-1010 operation guide gives one of a number of

  "4.3.3 Error Messages
  With the following errors, printing continues when you press the printer’s key. You can confirm these errors by printing a status page.

  File not found
  The specified file is not found

  KPDL Error
  Current print processing cannot continue.

  MemoryCard err##
  An error has occurred during access to the memory card using the PRESCRIBE RWER command or from the Remote Operation Panel.

  Memory overflow
  Printing cannot continue because there is not enough memory.

  Print overrun
  Current print processing cannot continue due to complex data.
  The data transferred to the printer was too complex to print on a page...To release the page protect mode, send the following command to the printer from the Remote Operation Panel after this error occurs: !R! FRPO R5, 1; EXIT;

  RAM DISK error ##
  Check the error code displayed in ## and refer to the appropriate
  description below.
  01: Abnormal format. Try turning the power off and on again.
  02: RAM disk mode is Off. Turn RAM disk mode On.
  04: No disk space. Clean up files.
  05: Specified file is not on disk.
  06: No memory for use by disk system. Expand printer memory."

  Pressed Go. Nothing happened. So. Reset printer. Print queue is empty.
  Gedit - 1-page doc: fine.
  Okular - 3-page pdf: fine.
  Gedit - 1-page pdf: fine.
  Open 182-page pdf, 41-page pdf, 20-page pdf, 128-page pdf, in Okular and...
  Okular - 3-page pdf: fine.
  Okular - 182-page pdf: prints 13 pages (pause after 5 for paper refill) and then stops. No lights flashing. After a few tens of seconds the printer queue clears.
  Gedit - 1-page doc: fine
  Okular - 20-page pdf: data jam (waited 15 mins). Data light on but nobody home.

  Reset printer without clearing queue.
  Nothing more happens (wait about 6 mins).
  Cancel job: printer still data-jammed.
  Reset printer.
  Okular - 20-page pdf: data jam (wait about 6 mins again)
  Reset printer. Clear print queue.
  Print web page from Firefox: nothing.
  Close down all open pdfs and open windows bar Firefox with 7-tabs and present desktop folder for printing. Takes about 5 to 10 mins to close up various matters. Then the Firefox webpage prints.
  Gedit - 1-page doc: fine.
  Firefox - data jam (waited 5 mins).

  Reset printer. Queue clear.
  Gedit - 1-page doc: fine.
  Okular - 2-page pdf: fine.
  Okular - 18-page pdf: printed up to half-way through page 15, of which it printed half a page. Then data jam.

  You get the picture. Could it be an O/S memory-handling problem?

  Over years of using Ubuntu, the Kyocera printer has been like this
  many times before. The printer driver often seems incapable. Then it
  works well for a stretch. Through previous installations of Ubuntu, it
  sometimes worked fine, sometimes not at all. The last status was that
  it worked but it was veeeeery slow printing pdfs. Now after the new
  install it barely works at all.

  Is there something fundamentally wrong here? What is it? After years
  of the same trouble I have to ask if its a Linux printing problem or
  just related to Kyocera on linux. Or is there something wrong with the
  release schedule that means that simple things that were nailed
  decades ago, like printing, and then nailed years ago in linux and
  long ago in Ubuntu, keep breaking every time Canonical issue a new
  release? The printing has screwed up again and again. This is printing
  we are talking about here. Has any user got time to waste on perpetual
  printer problems?

  So what has happened? I install the latest version of Xubuntu, I
  expect to be flying high. But no, I'm snarled up in some grotty
  traffic jam with exhaust blowing in my face. I can't get on with my
  job - the job I rely on Xubuntu to do. My snarled-up printer has
  become a metaphor for my box-fresh Xubuntu computer.

To manage notifications about this bug go to: