← Back to team overview

desktop-packages team mailing list archive

[Bug 478804] Re: Search and replace EOL character ^$ (to erase blank lines) doesn't work in Writer


Tested in LibreOffice 4.2.7 on Ubuntu 14.04 it works as expected, thus
closing as fix released.

** Changed in: libreoffice (Ubuntu)
       Status: Confirmed => Fix Released

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to libreoffice in Ubuntu.

  Search and replace EOL character ^$ (to erase blank lines) doesn't
  work in Writer

Status in libreoffice package in Ubuntu:
  Fix Released
Status in openoffice.org package in Ubuntu:
  Won't Fix

Bug description:
  Binary package hint: openoffice.org

  In OOo Writer 3.0.1, if you want to erase blank lines using 'search
  and replace' for ^$ (empty paragraph): either the blank lines are not
  found and nothing is replaced, either the styles may disappear and the
  replacement doesn't work before a page break.

  This worked perfectly in versions previous than Jaunty. It doesn't
  work in Jaunty nor in Karmic.

  If you add the extension "AltSearch 1.2.2 Alternative Find & Replace
  for Writer by Tomas Bilek", the extension does the job perfectly like
  Writer was able in the past versions.

  I've tried (before a reinstallation of Jaunty) to install OOo 3.1 (using the PPA I think) but the problem remained.
  In OOo 3.1.1 in Sabayon or in Parsix Linux, the problem doesn't exist.

  This is useful if you want to present a phonebook spreadsheet in a
  document in 4 columns with differents formats for the items: you can
  make a mailing from the spreadsheet but then you need to erase blank
  lines and page breaks and keep the formating.

  $ lsb_release -rd: Description:	Ubuntu 9.04        Release:	9.04
  $ apt-cache policy openoffice.org
    Installé : 1:3.0.1-9ubuntu3.1
    Candidat : 1:3.0.1-9ubuntu3.1
   Table de version :
   *** 1:3.0.1-9ubuntu3.1 0
          500 http://ftp.free.org jaunty-updates/main Packages
          500 http://ftp.free.org jaunty-security/main Packages
          100 /var/lib/dpkg/status
       1:3.0.1-9ubuntu3 0
          500 http://ftp.free.org jaunty/main Packages

  ProblemType: Bug
  Architecture: i386
  DistroRelease: Ubuntu 9.04
  NonfreeKernelModules: nvidia
  Package: openoffice.org-core 1:3.0.1-9ubuntu3.1
   PATH=(custom, no user)
  SourcePackage: openoffice.org
  Uname: Linux 2.6.28-16-generic i686
  Architecture: i386
  DistroRelease: Ubuntu 10.04
  InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
  NonfreeKernelModules: nvidia
  Package: openoffice.org 1:3.2.0-7ubuntu4
  PackageArchitecture: i386
  ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
  Tags: lucid
  Uname: Linux 2.6.32-22-generic i686
  UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

To manage notifications about this bug go to: