← Back to team overview

documentation-packages team mailing list archive

[Bug 1351092] Re: Configuration of the Droid Sans Fallback font


Well, you get DroidSansFallbackFull.ttf first, which is good. That's
what I got previously too (see comment #10 of bug #1335482), and it was
the intention with


However, after having tried various things back and forth, I don't get
that result any longer. Instead I get:

$ dpkg-query -W fonts-droid language-selector-common
fonts-droid	1:4.3-3ubuntu1
language-selector-common	0.129.2
$ LANG=zh_TW.UTF-8 fc-match -s sans-serif | head -5
DroidSans.ttf: "Droid Sans" "Regular"
uming.ttc: "AR PL UMing TW" "Light"
uming.ttc: "AR PL UMing HK" "Light"
ukai.ttc: "AR PL UKai TW" "Book"
DejaVuSans.ttf: "DejaVu Sans" "Book"

I.e. approximately the same result as Cheng-Chia Tseng reported in
comment #9 of bug #1335482. And that's not good, since it leads to "AR
PL UMing TW" being used to render traditional Chinese contents instead
of "Droid Sans Fallback".

So the result of the current configuration is unpredictable, and I'm
pretty sure by now that the culprit which causes this unpredictability
is 65-droid-sans-fonts.conf. The pending merge proposals should fix

I also think that the merge proposals will both fix bug #1334495 and
make it possible to use fonts-droid in the phone.

You received this bug notification because you are a member of
Documentation Packages, which is subscribed to fonts-android in Ubuntu.

  Configuration of the Droid Sans Fallback font

Status in “fonts-android” package in Ubuntu:
  In Progress
Status in “language-selector” package in Ubuntu:
  In Progress
Status in “fonts-android” source package in Trusty:
Status in “language-selector” source package in Trusty:

Bug description:
  There are currently several open issues related to the use of Droid
  Sans Fallback for rendering Chinese content:

  * Two mixed fonts when rendering Chinese in KDE/QT apps with Droid
    Sans fonts

  * Droid Sans no longer preferred font for Chinese

  * Chinese in Ubuntu Touch should use Heiti style sans serif font

  Unlike e.g. fonts-wqy-microhei, the fonts-droid package installs a
  bunch of fonts, of which only one is needed for Chinese. In an attempt
  to sort things out I have built the fonts-android source package in my
  PPA with the DroidSansFallbackFull.ttf font broken out to a separate
  binary package named fonts-droid-cjk. The PPA also includes a version
  of language-selector where the changes in version 0.129.2 have been

  To test it in Trusty, you should:

  * Uninstall the fonts-droid package

  * Install fonts-droid-cjk and language-selector-common from my PPA
    at https://launchpad.net/~gunnarhj/+archive/ubuntu/droid-test

  My own tests indicate that the change to language-selector due to bug
  #1335482 was a step in the wrong direction. With
  DroidSansFallbackFull.ttf as the only installed font from the Droid
  Sans family, you get rid of possible confusion that might have
  resulted in the issue reported in that bug.

  $ LANG=zh_CN.UTF-8 fc-match -s 'sans-serif' | head -n 5
  DroidSansFallbackFull.ttf: "Droid Sans Fallback" "Regular"
  uming.ttc: "AR PL UMing CN" "Light"
  uming.ttc: "AR PL UMing HK" "Light"
  ukai.ttc: "AR PL UKai CN" "Book"
  DejaVuSans.ttf: "DejaVu Sans" "Book"

  Also, if we would take this route, it might be easier to fix a
  configuration that makes Droid Sans Fallback work well with qt apps.
  (This is pure theory/hope so far.)

  Looking forward to your comments.

To manage notifications about this bug go to: