← Back to team overview

documentation-packages team mailing list archive

[Bug 299158] Re: Liberation Mono, Droid Sans Mono: Combining diacritics out of place


I tested this on Ubuntu 14.10 running gnome-terminal version 3.6.2 (with
UTF-8 encoding). I tried producing a captial "I" with strikethrough:

echo -e 'I\U0336'

The following font worked correctly:
 - Ubuntu Mono
 - Courier 10 Pitch
 - Droid Sans Mono
 - Free Mono
 - TlwgMono
 - TlwgTypo
 - Ubuntu Mono

The following fonts displayed the strikethrough incorrectly on the following character:
 - Dejavu Sans Mono
 - Liberation Mono
 - Monospace
 - Nimbus Mono L

See also this question:


You received this bug notification because you are a member of
Documentation Packages, which is subscribed to ttf-dejavu in Ubuntu.

  Liberation Mono, Droid Sans Mono: Combining diacritics out of place

Status in msttcorefonts package in Ubuntu:
  Won't Fix
Status in ttf-dejavu package in Ubuntu:
Status in ttf-droid package in Ubuntu:
Status in ttf-liberation package in Ubuntu:

Bug description:
  In the Liberation Mono font, combining diacritical marks are drawn
  over the following character rather than the preceding.

  According to the Unicode standard since at least version 3.0, chapter
  3.6, verse D56, combining characters apply to the preceding base
  character. However, this font renders them on the following base

  Version info:
  Ubuntu Intrepid
  ttf-liberation 1.04~beta2-2

  To reproduce:
  1. Open gedit.
  2. Type the following three code points: U+0061 U+0301 U+0065 (Latin small letter a, Combining acute accent, Latin small letter e).
  3. Via Edit|Preferences|Font & Colors|Font, select the Liberation Mono font.

  * Two grapheme clusters are displayed: Latin small letter a with acute accent, Latin small letter e.

  * The grapheme clusters displayed are: Latin small letter a, Latin small letter e with acute accent.

To manage notifications about this bug go to: