← Back to team overview

documentation-packages team mailing list archive

[Bug 1933758] Re: Display resolution not properly identifying in Ubuntu 21.04


Some bot incorrectly changed this to a docs bug. Changing back to
generic "Ubuntu".

** Package changed: ubuntu-docs (Ubuntu) => ubuntu

You received this bug notification because you are a member of
Documentation Packages, which is subscribed to ubuntu-docs in Ubuntu.

  Display resolution not properly identifying in Ubuntu 21.04

Status in Ubuntu:

Bug description:
  OK I am using Ubuntu 21.04 on a Raspberry pi 4 model B 4GB ram.My Monitor is LG Flatron E1942 with a resolution of 1366x768,It's a VGA monitor so I am using an HDMI to VGA converter to connect it with the monitor.This resolution is not automatically detected by Ubuntu,but it worked with Raspbian and Kali Linux.Therefore I edited the config.txt file and added these following lines hdmi_group=2,hdmi_mode=39 and hdmi_cvt=1366 768 60 3 0 0 1 otherwise the display will go blank, after editing this the monitor used to work with Ubuntu 20 (but still was not perfect,it got some black vertical lines in gnome but it worked perfectly fine with KDE-plasma)
  but after upgrading it to 21.04 this configuration doesn't work anymore.

  So at this point how the monitor work is like is this:
  1)If a turn on pi with monitor connected to it the boot menu and raspberry pi rainbow colors shows up,but the screen goes black once it enters gnome desktop.

  2)If I connect the monitor only after the pi enters gnome.The monitors
  shows up with a weird resolution(1280x720) but goes black if I open

  3)If I connect the monitor after the pi enters gnome.The monitors
  shows up with a weird resolution(1280x720) and I use xrandr in
  terminal to set resolution "again to 1280x720",at this point I can
  open settings and change the resolution to 1360x768.Once I set it to
  1360x768 the display is perfectly aligned,(I want this resolution
  every time I boot up without doing all these adventures)

  I have to repeat this step 3 every time I boot up the pi otherwise the screen goes blank.
  Kindly fix this bug.

  ProblemType: Bug
  DistroRelease: Ubuntu 21.04
  Package: ubuntu-docs 21.04.1
  ProcVersionSignature: Ubuntu 5.11.0-1012.13-raspi 5.11.21
  Uname: Linux 5.11.0-1012-raspi aarch64
  ApportVersion: 2.20.11-0ubuntu65.1
  Architecture: arm64
  CasperMD5CheckResult: unknown
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Jun 27 17:12:21 2021
  ImageMediaBuild: 20201022
  PackageArchitecture: all
   PATH=(custom, no user)
  SourcePackage: ubuntu-docs
  UpgradeStatus: Upgraded to hirsute on 2021-06-27 (0 days ago)

To manage notifications about this bug go to: