← Back to team overview

drizzle-discuss team mailing list archive

PROPOSAL: Rename plugin::InfoSchemaTable -> plugin::InfoSchemaView

 

Subject says it all.

INFORMATION_SCHEMA objects aren't tables, they are views, as they are only read-only materializations of data stored in other places (hash_map<>s, other real tables, HASHs, etc)

Thoughts?

-jay



Follow ups