← Back to team overview

drizzle-discuss team mailing list archive

Re: PROPOSAL: Rename plugin::InfoSchemaTable -> plugin::InfoSchemaView



On Dec 2, 2009, at 12:16 PM, Jay Pipes wrote:

> INFORMATION_SCHEMA objects aren't tables, they are views, as they are only read-only materializations of data stored in other places (hash_map<>s, other real tables, HASHs, etc)

I'd like to see an overall redesign of the naming conventions we use for it. Something that is thought out, pushed through the interface.