← Back to team overview

drizzle-discuss team mailing list archive

Re: PROPOSAL: Rename plugin::InfoSchemaTable -> plugin::InfoSchemaView


How about plugin::InformationSchemaRelation?

I don't like to think of views and tables as different things and much
prefer the term relation.


On Wed, Dec 2, 2009 at 5:46 PM, Brian Aker <brian@xxxxxxxxxxx> wrote:
> Hi!
> On Dec 2, 2009, at 2:21 PM, Monty Taylor wrote:
>> Because we currently have and InformationSchemaEngine which works with
>> InfomationSchemaTable objects. Just naming something
>> plugin::InformationSchema would imply that the plugin is providing an
>> entire InformationSchema, which it is not.
> Agreed, if it is in the class inheritance name that is fine.
> This though is why I wanted to see an overall plan first though :)
> I've been tempted to pull the word "Engine" from most of the "engines" for a while now. It is completely redundant.
> Cheers,
>        -Brian
> _______________________________________________
> Mailing list: https://launchpad.net/~drizzle-discuss
> Post to     : drizzle-discuss@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~drizzle-discuss
> More help   : https://help.launchpad.net/ListHelp

Follow ups