← Back to team overview

drizzle-discuss team mailing list archive

Re: PROPOSAL: Rename plugin::InfoSchemaTable -> plugin::InfoSchemaView


Stewart Smith wrote:
On Wed, Dec 02, 2009 at 09:53:51PM +0100, Roland Bouman wrote:
Oh, I forgot to mention - the term "view" would also be not entirely
appropriate in this case, because it can potentially be confused with
VIEW schema objects.
(which is why the information schema itself reports "SYSTEM VIEW" as
the TABLE_TYPE for information_schema tables, at least, in standard


for each of the I_S "tables" ?

seems reasonable to me. existing terminology++

Yes, I like this even more.


Follow ups