← Back to team overview

drizzle-discuss team mailing list archive

Re: PROPOSAL: Rename plugin::InfoSchemaTable -> plugin::InfoSchemaView

 


On 3 Dec 2009, at 16:33, Jay Pipes wrote:

Stewart Smith wrote:
On Wed, Dec 02, 2009 at 09:53:51PM +0100, Roland Bouman wrote:
Oh, I forgot to mention - the term "view" would also be not entirely
appropriate in this case, because it can potentially be confused with
VIEW schema objects.
(which is why the information schema itself reports "SYSTEM VIEW" as
the TABLE_TYPE for information_schema tables, at least, in standard
SQL)
plugin::InformationSchema::SystemView
for each of the I_S "tables" ?
seems reasonable to me. existing terminology++

Yes, I like this even more.


Why not remove all ambiguity, and make it "wide open" to interpretation:

plugin::InfoSchemaObject
plugin::InformationSchema::Object

The simple fact is that they are database objects of some sort, but they are not traditional "Views" or "Tables", and I'm sure others question "System View" too.. I doubt anybody could deny they are objects though.

Cheers,

Mark

--
Mark Leith
MySQL Regional Support Manager, Americas
Sun Microsystems, Inc., http://www.sun.com/mysql/







References