← Back to team overview

duplicity-team team mailing list archive

Re: [Question #660695]: duplicity fails with file too large error


Question #660695 on Duplicity changed:

Description changed to:

* duplicity 0.7.14
* gpg (GnuPG) 1.4.16
* Linux 3.13.0-29-generic (Ubuntu)

I had successfuly configured duplicity to remote backup content with
commands such as:

duplicity --encrypt-key D68E26B0 /etc

But it suddenly failed a few days ago with the following errors:

 GPGError: GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: [stdout]: write error: File too large
gpg: DBG: deflate: iobuf_write failed
gpg: build_packet failed: file write error
gpg: [stdout]: write error: File too large
gpg: iobuf_flush failed on close: file write error
gpg: [stdout]: write error: File too large
gpg: iobuf_flush failed on close: file write error
gpg: [stdin]: encryption failed: file write error
===== End GnuPG log =====

I have tried to reset the remote folder, removed local cache, reset gpg
keyring, even tried differente schemes, to no avail:

# LANG=en_US.UTH-8 duplicity --no-encryption /etc pexpect+scp://r2d2@xxxxxxxxxxxxxxxxx/duplicity/mendoza.xxxxxx.com/etc
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: none
No signatures found, switching to full backup.
Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1548, in <module>
  File "/usr/bin/duplicity", line 1534, in with_tempdir
  File "/usr/bin/duplicity", line 1383, in main
  File "/usr/bin/duplicity", line 1509, in do_backup
  File "/usr/bin/duplicity", line 573, in full_backup
  File "/usr/bin/duplicity", line 432, in write_multivol
    at_end = gpg.GzipWriteFile(tarblock_iter, tdp.name, globals.volsize)
  File "/usr/lib/python2.7/dist-packages/duplicity/gpg.py", line 443, in GzipWriteFile
  File "/usr/lib/python2.7/gzip.py", line 236, in write
    self.fileobj.write( self.compress.compress(data) )
  File "/usr/lib/python2.7/dist-packages/duplicity/gpg.py", line 419, in write
    result = self.fileobj.write(buf)
IOError: [Errno 27] File too large

This backup is small (77MB) anf there are plenty of available space on
both sides, even on /tmp/. Manual ssh to the remote user/host works.

Any idea?

You received this question notification because your team duplicity-team
is an answer contact for Duplicity.